Closed Bug 1331188 Opened 3 years ago Closed 3 years ago

Connection to ZNC bouncer fails

Categories

(Chat Core :: IRC, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1309063

People

(Reporter: micha.postbox, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170114030206

Steps to reproduce:

Setup was running until ZNC server was up/downgraded or whatever was changed.
Actual server version of ZNC 1.6.4 according webinterface.
Miranda IM works without problems.


Actual results:

(Thunderbird 45.6.0 (20161222195647), Gecko 45.6.0 (20161222195647) on Windows NT 10.0)
(57 messages omitted)
[14.01.2017 15:04:58] LOG   (@ prpl-irc: Socket.connect resource:///modules/socket.jsm:148)
Connecting to: bnc.stormbit.net:5050
[14.01.2017 15:04:58] DEBUG (@ prpl-irc: Socket.onTransportStatus resource:///modules/socket.jsm:553)
onTransportStatus(STATUS_RESOLVING)
[14.01.2017 15:04:58] DEBUG (@ prpl-irc: Socket.onTransportStatus resource:///modules/socket.jsm:553)
onTransportStatus(STATUS_RESOLVED)
[14.01.2017 15:04:58] DEBUG (@ prpl-irc: Socket.onTransportStatus resource:///modules/socket.jsm:553)
onTransportStatus(STATUS_CONNECTING_TO)
[14.01.2017 15:04:58] DEBUG (@ prpl-irc: Socket.onTransportStatus resource:///modules/socket.jsm:553)
onTransportStatus(STATUS_CONNECTED_TO)
[14.01.2017 15:04:58] LOG   (@ prpl-irc: Socket.sendString resource:///modules/socket.jsm:255)
Sending:
CAP LS

[14.01.2017 15:04:58] LOG   (@ prpl-irc: Socket.sendString resource:///modules/socket.jsm:255)
Sending:
PASS <password not logged>
[14.01.2017 15:04:58] LOG   (@ prpl-irc: Socket.sendString resource:///modules/socket.jsm:255)
Sending:
NICK TheRave

[14.01.2017 15:04:58] LOG   (@ prpl-irc: Socket.sendString resource:///modules/socket.jsm:255)
Sending:
USER TheRave/Mozilla 0 * TheRave

[14.01.2017 15:04:58] DEBUG (@ prpl-irc: Socket.onTransportStatus resource:///modules/socket.jsm:553)
onTransportStatus(STATUS_SENDING_TO)
[14.01.2017 15:04:58] DEBUG (@ prpl-irc: Socket.onTransportStatus resource:///modules/socket.jsm:553)
onTransportStatus(STATUS_RECEIVING_FROM)
[14.01.2017 15:04:58] DEBUG (@ prpl-irc: Socket.onStartRequest resource:///modules/socket.jsm:484)
onStartRequest
[14.01.2017 15:04:58] DEBUG (@ prpl-irc: ircSocket.prototype.onDataReceived resource://gre/components/irc.js:676)
{"rawMessage":":irc.znc.in CAP unknown-nick LS :palaverapp.com userhost-in-names multi-prefix znc.in/server-time-iso znc.in/batch znc.in/self-message","command":"CAP","params":["unknown-nick","LS","palaverapp.com userhost-in-names multi-prefix znc.in/server-time-iso znc.in/batch znc.in/self-message"],"origin":"irc.znc.in","tags":{},"source":""}
[14.01.2017 15:04:58] ERROR (@ prpl-irc: ircHandlers._handleMessage resource://gre/modules/ircCAP.jsm:47)
Error running command CAP with handler Client Capabilities:
{"rawMessage":":irc.znc.in CAP unknown-nick LS :palaverapp.com userhost-in-names multi-prefix znc.in/server-time-iso znc.in/batch znc.in/self-message","command":"CAP","params":["unknown-nick","LS","palaverapp.com userhost-in-names multi-prefix znc.in/server-time-iso znc.in/batch znc.in/self-message"],"origin":"irc.znc.in","tags":{},"source":"","cap":{"subcommand":"LS"}}
matches is null
[14.01.2017 15:04:58] WARN. (@ prpl-irc: ircSocket.prototype.onDataReceived resource://gre/components/irc.js:680)
Unhandled IRC message:
:irc.znc.in CAP unknown-nick LS :palaverapp.com userhost-in-names multi-prefix znc.in/server-time-iso znc.in/batch znc.in/self-message
[14.01.2017 15:06:59] DEBUG (@ prpl-irc: Socket.onTransportStatus resource:///modules/socket.jsm:553)
onTransportStatus(STATUS_RECEIVING_FROM)
[14.01.2017 15:06:59] DEBUG (@ prpl-irc: ircSocket.prototype.onDataReceived resource://gre/components/irc.js:676)
{"rawMessage":"ERROR :Closing link [Timeout]","command":"ERROR","params":["Closing link [Timeout]"],"origin":"bnc.stormbit.net","tags":{},"source":""}
[14.01.2017 15:06:59] WARN. (@ prpl-irc: ircBase.commands.ERROR resource://gre/modules/ircBase.jsm:164)
Received unexpected ERROR response:
Closing link [Timeout]
[14.01.2017 15:06:59] LOG   (@ prpl-irc: Socket.disconnect resource:///modules/socket.jsm:185)
Disconnect
Component: Instant Messaging → IRC
Product: Thunderbird → Chat Core
Version: 45 Branch → 45
This is bug 1309063, you seem to be using palaverapp.com, which uses an invalid IRC capability name. We've fixed this in TB 52, which is currently in aurora. I'll see about uplifting the fix for the next Thunderbird 45 release.

Thanks for filing the bug report!
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309063
You need to log in before you can comment on or make changes to this bug.