Addressbook UI copy/paste operations

RESOLVED DUPLICATE of bug 96968

Status

RESOLVED DUPLICATE of bug 96968
2 years ago
a year ago

People

(Reporter: andrixnet, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

This is a feature request. 
Currently there is no support practical for copy/paste operations within the Addressbook window.


Actual results:

no copy/paste operations function in Addressbook window UI. 
The only copy/paste available is when editing individual fields of a contact.


Expected results:

- having one or more contacts selected in the contacts list pane and pressing Ctrl-C should copy the contents of the shown fields as either plain text or basic HTML table
information as such on the clipboard should be paste-able into the addressbook.
- right click on contact -> copy email address (similar to context menu in TB on email links)
- a single email as plain text in the clipboard should paste as a new contact with only that email filled in.
- a comma separated list of emails in the clipboard should paste a new contacts, one for each email. (similar to how "To:" fields are filled in composition window)
- copy on an addressbook or list (adressbooks pane) should copy contacts according to the rule described above, 1st item
- contact details pane should allow text selection and copy of such selections.
- contacts details pane, email field should allow in context menu all operations that TB allows on an email link in message body. 
- exporting when one or more contacts are selected in contacts list pane and the pane has focus should export only those contacts (same as copy/paste operations)
- exporting when addressbook / list is selected in addressbooks pane should export that addressbook/list, provided that pane has focus

Comment 1

2 years ago
Thanks for these ideas.  Note, some of the items you mention should be seperate bugs.  That said, very likely some or all of your items are duplicate of an existing bug listed in https://mzl.la/2jMyt3m   Suggest you find the best match

Comment 2

2 years ago
Note that the TB address book is likely to be replaced completely at some stage, so we're investing minimum effort into it.
(Reporter)

Comment 3

2 years ago
As I see, it matches both #96968 and #365421 as well as many of their duplicates, each describing parts of it.

My report is more comprehensive and details a rather complete copy/paste functionality within the addressbook UI. 
Given the existing Bookmarks Organizer in Firefox, one would reasonably expect a similar level of functionality in TB addressbook, as they are equivalent.

Last but not least, bug #96968 is more the 15 years old. With all due respect, but this gives a whole new meaning to "the addressbook being low priority".

@Jorg: If that is the case, then I hope these reported issues will be taken into consideration in the new rewritten TB addressbook

Thank you.

Comment 4

2 years ago
Our practice in bugzilla is one bug report per issue.  As such I suggest filing new bugs for issues that aren't already open and this bug be closed.

A little summary to help you get started
- I'm not familiar with "export bugs" so I don't have advice about existing bugs.
- I suspect all other copy issues are covered by existing bugs (such as bug 339227), except perhaps item 4 "- a comma separated list of emails in the clipboard should paste a new contacts, one for each email. (similar to how "To:" fields are filled in composition window)"
As a practical matter this is either invalid (covering more than one issue) or a duplicate of bug 96968
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 96968
You need to log in before you can comment on or make changes to this bug.