Implement MOVZ, MOVN and MOVF instruction in MIPS32/MIPS64 simulator

RESOLVED FIXED in Firefox 54

Status

()

P5
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ivica.bogosavljevic, Assigned: ivica.bogosavljevic)

Tracking

Trunk
mozilla54
Points:
---

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

The MIPS32 and MIPS64 simulator do not implement MOVZ, MOVN and MOVF instructions. This causes failures in following tests:

ecma/String/15.5.4.7-1.js
ecma_7/String/string-pad-start-end.js
ecma_7/SIMD/splat.js
ecma_6/TypedArray/fill.js
ecma_6/Reflect/argumentsList.js

A patch implementing these instructions is attached. Please notice that simulator doesn't compile currently, so before landing this https://bugzilla.mozilla.org/show_bug.cgi?id=1329650 need to land.


Actual results:

The tests above failed


Expected results:

The tests shouldn't fail
Priority: -- → P5
(Assignee)

Comment 1

2 years ago
:(
Comment on attachment 8827136 [details] [diff] [review]
movz_movn_movf_simulator.patch

Hmm, this probably didn't catch people's attention because of its UNCONFIRMED status. Nicolas says Heiher is the right reviewer for this.
Attachment #8827136 - Flags: review?(r)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

2 years ago
Comment on attachment 8827136 [details] [diff] [review]
movz_movn_movf_simulator.patch

Review of attachment 8827136 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for late.
Attachment #8827136 - Flags: review?(r) → review+
(Assignee)

Comment 4

2 years ago
Hi Heiher!

This is the first time I am submitting the patch through bugzilla, so I have a question: I was looking
(Assignee)

Comment 5

2 years ago
Sorry for the interruption in the above comments. So I am rewriting it:

This is the first time I am submitting the patch through bugzilla, so I have a question: I was looking at the review but I don't see any comments in it? Am I missing something? What are the steps I need to take for this change to land?
I believe all you need to do is to add "checkin-needed" to the keyword field of the bug.  (Customarily you also assign the bug to yourself.)
(Assignee)

Comment 7

2 years ago
I do not have the permissions, please someone assign this issue to me.
Keywords: checkin-needed
Assignee: nobody → ivica.bogosavljevic

Comment 8

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/250c680482eb
"Implement MOVZ, MOVN and MOVF instruction in MIPS32/MIPS64 simulator" r=r
Keywords: checkin-needed

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/250c680482eb
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.