logging into password manager while logging into bugzilla crashes near 0x0 and 0xfeeefeee

RESOLVED DUPLICATE of bug 136434

Status

()

Core
XPCOM
--
critical
RESOLVED DUPLICATE of bug 136434
16 years ago
16 years ago

People

(Reporter: timeless, Assigned: Stuart Parmenter)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
cvs debug build from yesterday.  after removing wallet from installed-chrome 
and overlayinfo things started running right. [same build as bug 133089, but 
the wallet clean out made it significantly more useful]

I run mozilla, I get lots of js strict warnings, I browsed a bit and used 
bugzilla.

I went to resolve a test bugzilla bugzilla bug as invalid, and was prompted for 
my bugzilla login, and then my mozilla login.

Stack:
nsCOMPtr<nsIEventQueue>::assign_with_AddRef(nsISupports * 0x05adefc0) line 913 
+ 9 bytes
nsCOMPtr<nsIEventQueue>::operator=(nsIEventQueue * 0x05adefc0) line 585
nsEventQueueImpl::GetYoungestActive(nsEventQueueImpl * const 0x05adefc4, 
nsIEventQueue * * 0x0236fe60) line 569
nsEventQueueImpl::GetYoungestActive(nsEventQueueImpl * const 0x00cdba1c, 
nsIEventQueue * * 0x0236fe98) line 565 + 42 bytes
nsEventQueueServiceImpl::GetYoungestEventQueue(nsIEventQueue * 0x00cdba18, 
nsIEventQueue * * 0x0236fecc) line 247 + 47 bytes
nsEventQueueServiceImpl::GetThreadEventQueue(nsEventQueueServiceImpl * const 
0x002f8f80, PRThread * 0x003021f0, nsIEventQueue * * 0x0236ff18) line 386 + 41 
bytes
nsTimerImpl::Fire() line 428 + 57 bytes
TimerThread::Run(TimerThread * const 0x01699030) line 225
nsThread::Main(void * 0x01699320) line 120 + 26 bytes
_PR_NativeRunThread(void * 0x01699440) line 433 + 13 bytes
_threadstartex(void * 0x016996e8) line 212 + 13 bytes
KERNEL32! 77e8758a()

void
nsCOMPtr<T>::assign_with_AddRef( nsISupports* rawPtr )
  {
    if ( rawPtr )
      NSCAP_ADDREF(this, rawPtr); // <- crash here
-	this	0x0236fe40
\+	mRawPtr	0x00000000
-	rawPtr	0x05adefc0
\+	__vfptr	0xfeeefeee

In both nsEventQueueImpl::GetYoungestActive frames, *this is 0xfeeefeee

Updated

16 years ago
Keywords: crash

Comment 1

16 years ago
timeless, is this still a problem?
(Reporter)

Comment 2

16 years ago
probably :)

*** This bug has been marked as a duplicate of 136434 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.