Touch assitant W Firefox error

RESOLVED DUPLICATE of bug 1031210

Status

()

RESOLVED DUPLICATE of bug 1031210
2 years ago
2 years ago

People

(Reporter: lgbrowser5, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

10.00 MB, application/x-7z-compressed
Details
10.00 MB, application/octet-stream
Details
5.88 MB, application/octet-stream
Details
5.00 MB, video/mp4
Details
(Reporter)

Description

2 years ago
Created attachment 8827329 [details]
record_firefox.7z.001

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3; CNS_UA; GWX:MANAGED; AD_LOGON=4C47452E4E4554; rv:11.0) like Gecko

Steps to reproduce:

1. Platform Version (M): NOS(7.0)
2. Firefox version (M): Firefox 50.1, Firefox Beta 51.0
3. Reproducible on LG Ref. device (M) : Yes / G5 device
4. Reproduce rate (M) : 10/10
5. Issue Reported (M) : TD
6. Issue Description (Wrong behavior) (M) : Touch assitant 'W', Firefox browser does not launch or error page is displayed.
7. Expected behavior (M) : Firefox browser should be launched as blank page.
8. Steps to reproduce (M) :
1) Settings > General > Accessibility > Motor & cognition > Touch assistant ON
2) Touch assistant > `W` > Firefox
9. Screen Capture (M) : Yes(attached video)
10. MORE INFORMATION (O):
Touch assitant 'W' sends intent "ACTION_VIEW, CATEGORY_BROWSABLE, http://"

        Intent queryIntent = new Intent();
        queryIntent.setAction(Intent.ACTION_VIEW);
        queryIntent.addCategory(Intent.CATEGORY_BROWSABLE);
        queryIntent.setData(Uri.parse("http://"));
		

When it fixed, please share Engineering Report or Release info. for patches. 


Actual results:

Touch assitant 'W', Firefox browser does not launch or error page is displayed.


Expected results:

Firefox browser should be launched as blank page.
(Reporter)

Comment 1

2 years ago
Created attachment 8827330 [details]
record_firefox.7z.002
(Reporter)

Comment 2

2 years ago
Created attachment 8827331 [details]
record_firefox.7z.003
(Reporter)

Comment 3

2 years ago
Created attachment 8827332 [details]
record_chrome.mp4
Was the crash report at the end of the video submitted? If so then please provide the crash id. https://support.mozilla.org/en-US/kb/mozillacrashreporter

To get Firefox to load a blank page it would need to load "about:blank" without the quotes. Loading http:// is going to launch the default Firefox with http:// preinserted into the address bar.
(Reporter)

Comment 5

2 years ago
Dear 
this issue reproduce all devices.
I add hppt:// in memo , and open it.
It's same reproduce.
I report chash in mobile.
The issue state cannot be determined.
Where can I find it?
When it fixed ??
(Reporter)

Updated

2 years ago
Flags: needinfo?(kbrosnan)
Please provide the crash IDs. The following support document explains how to get crash ids https://support.mozilla.org/en-US/kb/mozillacrashreporter it applies to both desktop Firefox and Firefox for Android.
Flags: needinfo?(kbrosnan)
(Reporter)

Comment 7

2 years ago
Report ID 	
bp-7f52c73d-8026-4ae7-a8b1-4aa4e2170208
This is a known crash.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1031210
(Reporter)

Comment 9

2 years ago
this issue reproduce all devices.
I add "hppt://" in memo , and open it.
It's same reproduce.
I report chash in mobile.
Comment7 not in progress
When it fixed ??
Flags: needinfo?(mozilla)
(Reporter)

Updated

2 years ago
Flags: needinfo?(miket)
There is no fix at this time. I renominated the open bug 1031210 for Fennec tracking.
Mike Taylor is the wrong person to ask. Mike Kaply may be able to handle this.
Flags: needinfo?(miket)
The equivalent in Chrome:

adb shell am start -a android.intent.action.VIEW -c android.intent.category.default -d "http://"  -n com.android.chrome/com.google.android.apps.chrome.Main

I agree with kbrosnan, though, loading about:blank is a much safer thing to do.

adb shell am start -a android.intent.action.VIEW -c android.intent.category.default -d "about:blank"  -n com.android.chrome/com.google.android.apps.chrome.Main

and

adb shell am start -a android.intent.action.VIEW -c android.intent.category.default -d "about:blank" -n org.mozilla.firefox/.App

Both work well.

I am looking at fixing the crash, but I'm not sure it will result in the same behavior as Chrome.
Flags: needinfo?(mozilla)
You need to log in before you can comment on or make changes to this bug.