Explicitly pass lock proofs to TelemetryScalars thread unsafe functions

RESOLVED DUPLICATE of bug 1362957

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1362957
2 years ago
2 years ago

People

(Reporter: Dexter, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
1

Firefox Tracking Flags

(firefox53 affected)

Details

(Reporter)

Description

2 years ago
TelemetryScalar.cpp is prefixing all thread unsafe functions with the "internal_" prefix [1]. After it landed, we decided to change these functions so that their caller has to provide the proof it owns a lock.

This basically means we should add a |const StaticMutexAutolock&| parameter to each of the previously mentioned function and that the callers have to change to pass the lock as an argument, as done in TelemetryEvents.cpp [2].


[1] - http://searchfox.org/mozilla-central/search?q=internal_&case=false&regexp=false&path=TelemetryScalar.cpp
[2] - http://searchfox.org/mozilla-central/rev/c477aa8bd99278962998adba1c5e4b15a02c42c7/toolkit/components/telemetry/TelemetryEvent.cpp#274
(Reporter)

Updated

2 years ago
Blocks: 1275517
Points: --- → 1
Priority: -- → P3
(Reporter)

Comment 1

2 years ago
This was already addressed by a contributor in bug 1362957. Closing this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1362957
You need to log in before you can comment on or make changes to this bug.