Never Save option is not available when trying to login

RESOLVED WONTFIX

Status

()

P1
normal
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: hani.yacoub, Unassigned)

Tracking

(Blocks: 1 bug)

53 Branch
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

(Whiteboard: [fxprivacy])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8827385 [details]
Don't save.png

[Affected versions]: 
Nightly 53.0a1

[Affected platforms]:
All platforms: Ubuntu 16.04 x64, Windows 10 x 64, Mac OS X 10.11

[Steps to reproduce]:
1. Go to gmail.com and click on "Sign in".
2. Enter your email and password and click on "Sign in".
3. Click on "Save" from the permission pop-up.
4. Logout.
5. Try to login back again but with a different password.
6. Click "Update".
7. Login with the correct credentials.
8. Logout.
9. Sign in with a different account

[Expected result]:
"Never Save" option is not available from the permission pop-up.

[Actual result]:
Only two options are available, "Save" and "Don't Save".
(Reporter)

Comment 1

2 years ago
Created attachment 8827386 [details]
never save.png
(Reporter)

Updated

2 years ago
Blocks: 1188147
Component: Site Identity and Permission Panels → Password Manager
Product: Firefox → Toolkit
Priority: -- → P1
Whiteboard: [fxprivacy]
Relevant code is at https://dxr.mozilla.org/mozilla-central/rev/3e275d37a06236981bff399b7d7aa0646be3fee7/toolkit/components/passwordmgr/nsLoginManagerPrompter.js#988-999

Maybe the update case is getting hit here but the problem is that the doorhanger dynamically switches between Save and Update based on the typed username but that would mean the "Never Save" would have to dynamically appear to match old behaviour. The problem with Never Save is that it really means "Never Ask to Save" but on an update dialog a user may expect it to also delete their existing login which it doesn't.
Reading comment 2 I don't think this is actually actionable. If there's already a saved password "Never Ask" doesn't seem like a smart choice and the complex STR show that this is a case that most users will never hit. It's certainly rare enough to not warrant the amount of UX and engineering work this will likely require. I'll WONTFIX this. Feel free to reopen if you disagree.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.