Html5 Test CSP failing occasionally

RESOLVED INVALID

Status

()

Core
DOM: Security
RESOLVED INVALID
a year ago
4 months ago

People

(Reporter: Frank Orellana, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8827450 [details]
screen1.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170112171116

Steps to reproduce:

open http://html5test.com/ for the first time 
(I have only been able to reproduce it with some tabs open, and also after installation, but it happens and in several versions of windows. It does not happen in subsequent loads of the page so it's been hard to reproduce but I attach the screens)


Actual results:

The first time executed it will show 468 out of 555, and the "Content Security Policy 1" security test failed.


Expected results:

The normal execution shows 471 out of 555, and the "Content Security Policy 1" security test succeeded.
(Reporter)

Comment 1

a year ago
Created attachment 8827451 [details]
screen2.jpg

Comment 2

a year ago
[bugday-20170118] 
Unable to reproduce this on Nightly 52.0a2 (2017-01-17) (64-bit) on Linux Mint 64bit.
The score remained same on multiple tests and Content Security Policy 1 passes everytime

Updated

a year ago
Component: Untriaged → DOM: Security
Product: Firefox → Core

Comment 3

a year ago
WFM with FF51: "Your browser scores 471 out of 555 points"

Could you retest with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(lando.orellana+bz)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

4 months ago
Can't seem to reproduce this in newer versions.
Flags: needinfo?(lando.orellana+bz)
Resolution: INCOMPLETE → INVALID
You need to log in before you can comment on or make changes to this bug.