Bootstrap should install rust std (error[E0463]: can't find crate for `std`)

RESOLVED DUPLICATE of bug 1324435

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1324435
a year ago
a year ago

People

(Reporter: Benjamin Smedberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
0:06.52 checking cargo support for --frozen... yes
 0:06.81 DEBUG: Executing: `c:/Users/benja/.cargo/bin/rustc.exe --crate-type staticlib --target=i686
-pc-windows-msvc -o 'c:\users\benja\appdata\local\temp\conftestvnmdxq.rlib' 'c:\users\benja\appdata\
local\temp\conftestol19k9.rs'`
 0:06.81 DEBUG: The command returned non-zero exit status 101.
 0:06.81 DEBUG: Its error output was:
 0:06.81 DEBUG: | error[E0463]: can't find crate for `std`
 0:06.81 DEBUG: |
 0:06.81 DEBUG: | error: aborting due to previous error
 0:06.81 DEBUG: |
 0:06.81 ERROR: Cannot compile for i686-pc-mingw32 with c:/Users/benja/.cargo/bin/rustc.exe
 0:06.81 The target may be unsupported, or you may not have
 0:06.81 a rust std library for that target installed. Try:
 0:06.81
 0:06.81   rustup target add i686-pc-windows-msvc

<froydnj> bsmedberg: windows?  you probably need to install the x86 runtime libraries via rustup
<bsmedberg> yes windows
<bsmedberg> should bootstrap have done that for me?
<froydnj> in an ideal world, yes
* bsmedberg is dedicated to making this world more ideal
<froydnj> let us say then that mach bootstrap is in a non-ideal state at the moment

Although the configure error message says how to rectify the problem, it shouldn't be a problem in the first place, because bootstrap should leave you with a working config.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1324435
You need to log in before you can comment on or make changes to this bug.