Mozilla crashes if you run "make" in packaging directory while running mozilla from dist/bin

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Build Config
P2
critical
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: André Dahlqvist, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Trunk
mozilla1.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
[CVS tree from 2002-03-24-19]
[Not sure about component, please reassign at will]

I have noticed a rather funny crasher that happens if you run "make" in the
xpinstall/packager directory at the same time as you run mozilla from dist/bin.
Here are the steps to reproduce:

1) Start a cvs build from the .../dist/bin/ directory. For me that is
mozilla/obj-i686-pc-linux-gnu/dist/bin/.
2) In another xterm, go to xpinstall/packager and run "make".

Result: Mozilla will die after a few seconds with a "bus error".

This is 100% reproducable, so I assume that the packaging process is doing
something with the binaries and libraries that makes the browser crash. I do not
have a debug build right now, so I cannot get a stack trace for you.
(Reporter)

Updated

17 years ago
Severity: normal → critical
(Reporter)

Comment 1

17 years ago
Just to clarify, with "Start a cvs build from the..." I mean "Start the browser
that you have built in your cvs tree.
@%#$%@%! This is a change in the behavior of GNU fileutils.  On RH6.2 with
fileutils 4.0-21, 'cp -rp' deferences the links.  On RH 7.2 with fileutils
4.1-4, it does not.  4.1 has an option, -L, to force symlink dereferencing but
4.0 does not and I'm not sure if non-GNU cps do either.   Looks like we're
headed towards tar solution.


Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 3

17 years ago
Actually I would prefer a TAR solution.
If you look at bug http://bugzilla.mozilla.org/show_bug.cgi?id=66368
you will note that HP's cp will copy the links and resolve the links
and copy the file.  So it looks like this is the same issue.
Using tar instead of cp would help us on HP.
Created attachment 76647 [details] [diff] [review]
Use tar instead of cp

Comment 5

17 years ago
This solves my HP problem... if it matters r=jdunn@netscape.com

Comment 6

17 years ago
*** Bug 66368 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Comment on attachment 76647 [details] [diff] [review]
Use tar instead of cp

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #76647 - Flags: approval+
Patch checked in.

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

17 years ago
Running "make" doesn't kill mozilla anymore. The packaging process still works,
so all is well.

VERIFIED FIXED with CVS from 2002-03-30-10 on Linux.
Status: RESOLVED → VERIFIED

Comment 10

17 years ago
phew, you scared me with this change :). Thought I had been subverted, because
make dist changed behaviour.

What happens is that when I execute make dist (MOZ_PKG_FORMAT=BZ2), I just get a
   (stdin:)
prompt and nothing happens. Before the change, it worked fine. Chaning the tar
command to |tar xIf <package> <dist>| works, too.

Comment 11

17 years ago
eh, tar cIf, of course.

Comment 12

17 years ago
oh, sorry, nevermind. After looking at the change, I tried again and it works. I
was just confused by the lack of the feedback I am used to (the operation takes
30-60s on that machine).
Sorry about that.  I didn't see the point of having those files listed multiple
times and I didn't see the point of having 2 versions of TAR_CREATE_FLAGS (one
for MAKE_PACKAGE and the other for the dist/bin copy).
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.