Support {Ctrl,Cmd}-Shift-v for pasting unformatted text

RESOLVED DUPLICATE of bug 1327798

Status

()

Core
Editor
P3
normal
RESOLVED DUPLICATE of bug 1327798
a year ago
a year ago

People

(Reporter: cpeterson, Unassigned)

Tracking

44 Branch
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(platform-rel +, firefox50 affected, firefox51 affected, firefox52 wontfix, firefox53 affected)

Details

(Reporter)

Description

a year ago
STR:
1. In a Google Doc, copy some formatted text.
2. Press the Windows keyboard shortcut CTRL+SHIFT+V to paste the plain text without formatting back into the Google Doc.

RESULT:
The formatted rich text is pasted instead of plain text.

CTRL+SHIFT+V in Google Docs works correctly in Chrome. In Edge, CTRL+SHIFT+V doesn't paste any text.
I didn't know about Ctrl-Shift-v! Michael, you (reluctantly) know about pasting; can you take a look here?
platform-rel: ? → +
Flags: needinfo?(michael)

Comment 2

a year ago
(In reply to Andrew Overholt [:overholt] from comment #1)
> I didn't know about Ctrl-Shift-v! Michael, you (reluctantly) know about
> pasting; can you take a look here?

As far as I know, we don't have an editor command for un-formatted pasting, which would explain why that keyboard shortcut doesn't do anything for us. It shouldn't be too difficult to add a command like that however, I would think.
Flags: needinfo?(michael)
(Reporter)

Comment 3

a year ago
CTRL+SHIFT+V on Windows and CMD+SHIFT+V on Mac are standard keyboard shortcuts for unformatted pasting of formatted text.
I suspect we want to move this to a different component but I'm not sure what's best.
Priority: -- → P3
Summary: CTRL+SHIFT+V pastes formatted text into Google Doc instead of plain text → Support {Ctrl,Cmd}-Shift-v for pasting unformatted text

Comment 5

a year ago
I think that this is an editor bug.
Component: Serializers → Editor
(Reporter)

Comment 6

a year ago
Copying formatted HTML from a web page will be correctly pasted into a Google Doc without formatting by Ctrl+Shift+V. The problem only seems to affect rich editors, such as copying from Google Doc or the Mana Confluence editor into Google Doc.

Comment 7

a year ago
We already implement this and it works fine in most cases for a simple test such as:

data:text/html,<body contenteditable="true"><b>Bold</b> Test</body>

Possibly something specific to Google docs? Does it try to override the shortcut and perform its own operation?
See Also: → bug 1327798
Mass wontfix for bugs affecting firefox 52.
status-firefox52: affected → wontfix
When I test this today using the latest Nightly, I cannot reproduce this.  I think that this is fixed by bug 1327798.

If this isn't fixed by 54 or 55, please reopen this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1327798
You need to log in before you can comment on or make changes to this bug.