javascript not read when given the linked through the src=" " within head-tags

RESOLVED DUPLICATE of bug 132673

Status

--
major
RESOLVED DUPLICATE of bug 132673
17 years ago
14 years ago

People

(Reporter: ghlenn, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020324
BuildID:    20020324

browser does not read/acknowledge any given javascript when the source should be
fetched through the  src="file.js" inside the javascript tag within the head tags

Reproducible: Always
Steps to Reproduce:
1.Any page w/ javascript source read through a source file
2.
3.

Actual Results:  page does not work as it should

Expected Results:  javascript should be properly read into and parsed by the browser

The problem shows itself also when using Linux 20020321;
No problem when using Netscape 6.2.2 for Windows

Comment 1

17 years ago
how about a test case?

Comment 2

17 years ago
See http://www.kryptolus.com/mozilla/133176.html
Javascript is loaded as expected ...

Can you provide us with a test case that fails to work as expected?
(Reporter)

Comment 3

17 years ago
Created attachment 75965 [details]
testcase, .js-example, errormessages

Testcases: 
http://www.abc.se/~gw/rot/limerick.html
http://www.abc.se/~gw/rot/randomly.html
http://www.abc.se/~gw/rot/tp.html (attached)
----------------
tp.js example:
var urlarray = new Array("example",
"example",
"example",
"lastone");
-------------------
Error messages:
Error: redeclaration of const hide
 Source File: chrome://wallet/content/walletOverlay.js Line: 1
Error: popup has no properties
 Source File: chrome://messenger/content/mailNavigatorOverlay.xul Line: 100

Comment 4

17 years ago
Ghlenn,

This is most likely a dupe of bug 132673.
All of the examples use document.write to add data to the document.
The first one uses document.write to add <script> tags to the document.

If this still occurs after bug 132673 is fixed, please reopen this bug.

*** This bug has been marked as a duplicate of 132673 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
FYI, the errors in the javascript console are unrelated.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.