./mach talos-test --suite tp5o --spsProfile takes forever to generate profiles

RESOLVED DUPLICATE of bug 1358818

Status

defect
RESOLVED DUPLICATE of bug 1358818
2 years ago
2 years ago

People

(Reporter: bholley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_wishlist])

(Reporter)

Description

2 years ago
I just did a tp5o run on a normal build with --spsProfile. The run completed, and then it started generating profiles:

15:33:07     INFO -  Adding profile profile_tp5o/56.com/cycle_0.sps to archive /files/mozilla/repos/yy/testing/mozharness/build/blobber_upload_dir/profile_tp5o.sps.zip
15:36:57     INFO -  Adding profile profile_tp5o/aljazeera.net/cycle_0.sps to archive /files/mozilla/repos/yy/testing/mozharness/build/blobber_upload_dir/profile_tp5o.sps.zip
15:41:01     INFO -  Adding profile profile_tp5o/amazon.com/cycle_0.sps to archive /files/mozilla/repos/yy/testing/mozharness/build/blobber_upload_dir/profile_tp5o.sps.zip
15:46:26     INFO -  Adding profile profile_tp5o/bbc.co.uk/cycle_0.sps to archive /files/mozilla/repos/yy/testing/mozharness/build/blobber_upload_dir/profile_tp5o.sps.zip
15:51:16     INFO -  Adding profile profile_tp5o/beatonna.livejournal.com/cycle_0.sps to archive /files/mozilla/repos/yy/testing/mozharness/build/blobber_upload_dir/profile_tp5o.sps.zip
15:58:02     INFO -  Adding profile profile_tp5o/bild.de/cycle_0.sps to archive /files/mozilla/repos/yy/testing/mozharness/build/blobber_upload_dir/profile_tp5o.sps.zip
16:03:17     INFO -  Adding profile profile_tp5o/cgi.ebay.com/cycle_0.sps to archive /files/mozilla/repos/yy/testing/mozharness/build/blobber_upload_dir/profile_tp5o.sps.zip

Each one took about six minutes (note the timestamps), so I eventually killed the process. They also appeared to be overwriting the zip file each time?

Combined with bug 1331806, this makes for rather bad ergonomics when trying to profile a single Talos page locally.


My .mozconfig (the LDFLAGs are stylo stuff, but I don't have stylo enabled on this build, so I doubt they're related to the bug here).

export LDFLAGS=-Wl,-no_compact_unwind
mk_add_options AUTOCLOBBER=1
mk_add_options CARGOFLAGS="--color always"
ac_add_options --enable-warnings-as-errors
ac_add_options --enable-rust

ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --enable-profiling
Whiteboard: [talos_wishlist]
The last time I ran into this, the issue seemed to be that it was contacting the symbolication server for every profile, and it apparently started throttling me after a couple of runs.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358818
You need to log in before you can comment on or make changes to this bug.