Mozilla enters an infinite malloc loop

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Robert Mende, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313
BuildID:    0.9.9

When trying to "enter" one of the delphi forums (tried multiple instances, and
the same thing happens), mozilla appears to hang.   The process will use all
available CPU on the the system and given time will consume all memory on the
system.  Stracing the proess shows it constantly calling brk.  

I can reproduce this at will (sigh) an will be happy to help.

Reproducible: Always
Steps to Reproduce:
1. Login to delphi forums (need to create an account)
2. Select a "forum" ... I have seen this on "Camp Bob" and others
3. Select a "thread" inside that forum.  ... Bug will now occur.



Looking at the strace, the last thing we see before the brk loop I see a very
long html page (37k) that starts off with

/*HM_ScriptDOM.js
* by Peter Belesis. v4.1.3 011108
* Copyright (c) 2001 Peter Belesis. All Rights Reserved.
* Originally published and documented at http://www.dhtmlab.com
* Available solely from INT Media Group. Incorporated under exclusive license.
* Contact licensing@internet.com for more information.
*
*/
Extra param used for menu clicks
ng_extraParam = \"\";
HM_IE5M = HM_IE && HM_Mac;
HM_IE5W = HM_IE && !HM_Mac;
HM_NS6 = (navigator.vendor == (\"Netscape6\") || navigator.product == (\"Gecko\"));
HM_IEpos = HM_IE || (HM_NS6 && ParseInt(navigator.productSub)>=20010710);
HM_IECSS = (HM_IE && document.compatMode) ? document.compatMode == 
\"CSS1Compat\" : false;
HM_IEDTD = (HM_IE && document.doctype) ?
document.doctype.name.indexOf(\".dtd\")!=-1 : HM_IECSS;

HM_IEnoDTD = HM_IE && !HM_IEDTD;

Comment 1

17 years ago
If you save the page locally, does it still hang?  If so, could you attach the
page here?

Please try a newer (nightly) build, too.
(Reporter)

Comment 2

17 years ago
When loading parts of the frameset from local disk (saved via netscape 4.7) I
did not get the hang.

When fixing up the frameset to load local disk copies I did not net the hang.
(Reporter)

Comment 3

17 years ago
Confirms this happens on nigtly build mozilla-i686-pc-linux 0.9.9-20020324 from
mozilla.org

Comment 4

17 years ago
It seems I cannot reproduce it with 23rd march build for Windows.

Build ID : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+) Gecko/20020323

Comment 5

17 years ago
And I cannot see that bug with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:0.9.9+) Gecko/20020324 build.

Seems to be a linux related bug. Strange !

Comment 6

16 years ago
I can't reproduce it either with linux trunk 2002041718

Comment 7

16 years ago
Robert, does this still happen on a current build ?
no answer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.