Closed Bug 1331835 Opened 5 years ago Closed 4 years ago

Incorrect attribute name of videocontrol.xml. `aria-hideen` should be `aria-hidden`

Categories

(Toolkit :: Video/Audio Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: ralin, Assigned: jaws)

Details

(Keywords: access)

Attachments

(1 file, 1 obsolete file)

There's a typo of aria-hidden attribute in videocontrols.xml [0].

<div class="controlsSpacerStack" aria-hideen="true">
should be fixed to like:
<div class="controlsSpacerStack" aria-hidden="true">



[0] https://dxr.mozilla.org/mozilla-central/rev/6a23526fe5168087d7e4132c0705aefcaed5f571/toolkit/content/widgets/videocontrols.xml#146
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Hi Jared,

Sorry that I forgot to add more context about this bug. I tried to add this fix in bug 1325591 but failed due to a11y test[0], so I filed a new bug for it. I'm afraid that we might need more than fixing typo here.


[0] https://bugzilla.mozilla.org/show_bug.cgi?id=1325591#c27
Hi Alex,

It seems that we could not launch DOMi now, so I had a problem inspecting a11y tree in anonymous content. Is there any alternative or proper approach to debug a11y related bug?

Thanks
Flags: needinfo?(surkov.alexander)
You can launch DOMi but it takes a few steps first.
1. Disable e10s and restart the browser
2. Enable DOMi and restart the browser (these first two steps can be done in the opposite order too)
3. Open the New Tab Page
4. Launch DOMi

Then you should be able to inspect the video controls.
Yep this is a only way to keep the DOMi working. Alternatively, you could try desktop tools, each platform provides something for accessible tree inspection.
Flags: needinfo?(surkov.alexander)
Okay, I didn't realize that we would have to make more changes. Ray, would you like to take this bug then?
Assignee: jaws → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(ralin)
Thank you Jared and Alex :)


I would take this bug, but my queue is quite full recently due to other higher priority regressions. keep NI flag.
Comment on attachment 8828391 [details]
Bug 1331835 - Fix typo of aria-hidden in videocontrols.xml.

https://reviewboard.mozilla.org/r/105822/#review107262
Attachment #8828391 - Flags: review?(ralin)
Attachment #8828391 - Attachment is obsolete: true
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(ralin)
Comment on attachment 8922368 [details]
Bug 1331835 - Remove unused aria-hideen since the typo was causing it to be unused and correcting the typo changes the accessible tree.

https://reviewboard.mozilla.org/r/193418/#review198646

Thanks :D
Attachment #8922368 - Flags: review?(ralin) → review+
Comment on attachment 8922368 [details]
Bug 1331835 - Remove unused aria-hideen since the typo was causing it to be unused and correcting the typo changes the accessible tree.

https://reviewboard.mozilla.org/r/193418/#review198716

I don't know this code, but the change looks correct: aria-hideen cannot be confused with aria-hidden by AT or a11y engine.
Attachment #8922368 - Flags: review?(surkov.alexander) → review+
(In reply to alexander :surkov from comment #11)

> I don't know this code, but the change looks correct: aria-hideen cannot be
> confused with aria-hidden by AT or a11y engine.

at least until we or they have same typo ;)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/138e83fdc400
Remove unused aria-hideen since the typo was causing it to be unused and correcting the typo changes the accessible tree. r=ralin,surkov
https://hg.mozilla.org/mozilla-central/rev/138e83fdc400
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.