Keep last active window and tab in view during session restore

RESOLVED DUPLICATE of bug 1034036

Status

()

RESOLVED DUPLICATE of bug 1034036
2 years ago
7 months ago

People

(Reporter: mikedeboer, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxperf])

(Reporter)

Description

2 years ago
We’re not keeping the last active window and the last active tab in that window in front of the user whilst restoring. Ideally, other windows and tabs would open in the background, out of sight.

Yoric tried to do this several years ago and failed, due to limitations in XUL. I still believe that this would be good, but this will need some OS-specific C++ tweaking.

We will fix this per platform, in the following order:
- first a version that improves only, say, Windows 8+ (or Windows 10+);
- then a second version that also improves MacOS;
- then another version that also improves Linux.

As long as improvements on a single platform don't break other platforms, this will be a net gain.

Work on each platform specifically should be done in bugs blocking this one.
Can we open the last selected window/tab first? This way users can start interacting with Firefox as soon as they see the first window.
If we open another window first and then focus the last selected window when we open it, users will need to wait.

Comment 2

2 years ago
Yes, I think Marco is right.  We should absolutely not change the z-order of windows after opening them, we should compute the exact ordering and just start opening in the reverse order.  Soon hopefully we're going to be removing all of the reasons we're stupidly slow at restoring the session and then if we have the correct ordering the windows can "shuffle" up in the correct order on to the screen like a deck of cards.  Hopefully without janking.  :-)
(Reporter)

Comment 3

2 years ago
Marco, Ehsan, both your comments summarize the desired outcome of this bug as I see it. For me personally, this is currently the worst offender for perceived slow performance when restoring multiple windows with multiple tabs. At least on OSX, but I'm sure there's work to do on the other platforms as well.
(Reporter)

Updated

2 years ago
See Also: → bug 1034036
(Reporter)

Updated

2 years ago
Depends on: 1034036
Keywords: meta
See Also: bug 1034036
(Reporter)

Updated

a year ago
Depends on: 1235231
Whiteboard: [fxperf]
(Reporter)

Comment 4

7 months ago
I think this has been implemented in SessionStore.jsm in bug 1034036.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1034036
You need to log in before you can comment on or make changes to this bug.