Closed Bug 1331946 Opened 5 years ago Closed 5 years ago

In Nightly, Talkback no longer reads any web content.

Categories

(Firefox for Android Graveyard :: General, defect)

53 Branch
Unspecified
Android
defect
Not set
normal

Tracking

(fennec+)

RESOLVED DUPLICATE of bug 1332731
Tracking Status
fennec + ---

People

(Reporter: rdanbrown, Assigned: jchen)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

1.  With Talkback running, either enter a URL into the address bar, or select a site from Bookmarks/History.
2.  Note that Nightly no longer provides "Loading" feedback to indicate that the page is still being loaded or when page load is complete.
3.  Once the page finishes loading, swipe forward, and note that no content is read after the Menu button.  Using Explore by Touch under the top menu bar also yields no result.


Actual results:

No content was read.


Expected results:

"Loading" should've been verbalized until the page finished loading, at which point "Load Complete" should've been announced.  Content should then have been available through Explore by Touch or swiping forward.
OS: Unspecified → Android
tracking-fennec: --- → ?
Hi Sorina,
If this bug can be reproduced, could you provide a regression window?
Flags: needinfo?(sorina.florean)
Hello and sorry for delay here!

Regression window:
Last known good build: 2016-12-10
First known bad build: 2016-12-11

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8404d26166a35406f46ff237ed132735c98882b2&tochange=c51e7406d7b2e2246a1ece0d8989282ca752039f

Device: Huawei MediaPad M2 (Android 5.1.1).
Flags: needinfo?(sorina.florean)
One observation: the regression window was performed for step 2 from description. I couldn't reproduce step 3, the content was read and for all the buttons I tapped as well.
(In reply to Sorina Florean [:sorina] from comment #3)
> One observation: the regression window was performed for step 2 from
> description. I couldn't reproduce step 3, the content was read and for all
> the buttons I tapped as well.

After further investigation, I could reproduce step 3 as well.
similar regression window as bug 1332731 on talkback function.
Flags: needinfo?(nchen)
See Also: → 1332731
Assignee: nobody → nchen
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(nchen)
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1332731
tracking-fennec: ? → -
Tracking flags should match the duped bug. This is done in case the bug's duplicate status is removed.
tracking-fennec: - → +
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.