Only the sound plays on youtube when RDM is active and a device selected

RESOLVED INVALID

Status

DevTools
Responsive Design Mode
RESOLVED INVALID
a year ago
6 days ago

People

(Reporter: ccomorasu, Unassigned)

Tracking

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 affected, firefox53 affected)

Details

(Whiteboard: [rdm-v2])

[Affected versions]:
 Fx 52.0a2 (20170118004007)
 Fx 53.0a1 (20170113030227)

[Affected platforms]:
 Windows 10 x64
 Mac OS X 10.11

[Steps to reproduce]:
 1. Open Firefox.
 2. Go to "www.youtube.com".
 3. Open RDM (ctrl/cmd+shift/alt+m).
 4. Select "Apple iPhone 4" from the list.
 5. Play a video.

[Expected result]:
 The video plays without any issues.

[Actual result]:
 Only the sound starts.

[Regression range]:
 This issue is not a regression as it is reproducible ever since it was implemented.

[Notes]:
 a. Gif with the issue: http://imgur.com/a/AJ8mu .
 b. This issue is reproducible when selecting "Apple iPhone 4" at step 4 from STR.
 c. This issue is not reproducible on Ubuntu.
QA Whiteboard: [qe-rdm]
This issue is also reproducible on Ubuntu. Ignore the note c. from the description. Thank you!
It appears YouTube uses UA detection to choose how to play the video.  In particular, it looks at the iOS version in UA for iPhones.  If it is less than 5.x (as is the case with our iPhone 4 entry), then it seems to choose a video playback method that fails in Firefox.

I don't think there's anything we can do here.  The site is heavily UA customized, so it's possible for some things to break in this way when we aren't using the browser engine that matches the UA.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Whiteboard: [rdm-v2] [triage] → [rdm-v2]

Updated

6 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.