Test/improve binary data handling

VERIFIED DUPLICATE of bug 3342

Status

Directory
PerLDAP
P4
minor
VERIFIED DUPLICATE of bug 3342
19 years ago
18 years ago

People

(Reporter: Leif Hedstrom, Assigned: Leif Hedstrom)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
Some users have had problems with binary data, like JPEG photo. This might be a
documentation issue, but we should look into it.

For instance:

Leif:
 Hi, I am Frank Villavicencio, working in IT at Morgan Stanley in NYC. I
am currently doing some development using the PerLDAP 1.0 libraries from
Netscape, of which you have wrote most.
 Being unable to access the news forum for Mozilla, I took the liberty
of e-mailing you directly, I hope you excuse the abuse, my apologies in
advance.
 In any case, my question is with regard to attributes with binary
values (jpegphoto). I am taking a changeLogEntry from an LDAP server in
order to propagate changes to other servers, all through a perl script.
But I haven't been successful at propagating binary values. It seems
like the method Mozilla::LDAP::Entry->addValue() interprets anything as
text, despite of any type of value being passed. I have tried to use
Mozilla::LDAP::Utils(qw(decodeBase64)) in order to fool it, but it
doesn't seem to work.
 Is there any way to deal with this issue in this release of PerLDAP?,
if not, is there any release or work around for this?.
 Thanks a lot, I appreciate your answer.

-Frank

        Frank Villavicencio <villaf@ms.com>
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Priority: P2 → P3
(Assignee)

Updated

19 years ago
Priority: P3 → P5
(Assignee)

Updated

19 years ago
Priority: P5 → P3
(Assignee)

Updated

19 years ago
Priority: P3 → P4

Comment 1

19 years ago
This is a duplicate of bug 3342

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
*** This bug has been marked as a duplicate of 3342 ***

Comment 3

18 years ago
verified duplicate of 3342.  
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.