Re-enable installing unverified addons

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
9 months ago
9 months ago

People

(Reporter: SashaChernykhEmpressOfUniverse, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

For example, I want to install GhostText addon — https://addons.mozilla.org/en-US/firefox/addon/ghosttext/ . Add To Firefox → add to Firefox → I get error 

«Firefox has prevented this site from installing an unverified addon»:

http://i.imgur.com/kdKiW17.png

I have no interest in doing this for a personal project, and no interest in distributing it in a store. I only want the add-on for personal use.


Actual results:

I can not install unverified addons for me, besides GhostText I get this errors for some addons. Set «xpinstall.signatures.required» to «false» now not working for me, from version 48.0 — https://support.mozilla.org/en-US/questions/1134589 .

1. Yes, I understood risks.
2. I don't want use Firefox Developer or Nightly.
3. I don't want to install addons temporarily each time.



Expected results:

Firefox — is the most tunable browser. It is very bad, что Firefox does not allow users to decide which addons they need. Yes, setting must be is disabled by default, but why Firefox banned customize the setting?

Thanks.
(Reporter)

Updated

9 months ago
Summary: Re-enable Installing unverified addons → Re-enable installing unverified addons

Updated

9 months ago
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit

Comment 1

9 months ago
The reasonsing for signing has been discussed at length elsewhere.
Your list of rejected options is missing a few things.  You can also run an unbranded build or you can get the addon signed but keep it unlisted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

9 months ago
(In reply to Andrew Swan [:aswan] from comment #1)
> The reasonsing for signing has been discussed at length elsewhere.
> Your list of rejected options is missing a few things.  You can also run an
> unbranded build or you can get the addon signed but keep it unlisted.

@Andrew Swan,

> The reasonsing for signing has been discussed at length elsewhere.

In official Mozilla sites I read only discussion in Mozilla blog, where all users criticized the solution — https://blog.mozilla.org/addons/2016/07/29/extension-signing-availability-of-unbranded-builds/ . Where I can read about reasons of solution from Mozilla developers?

> You can also run an unbranded build or you can get the addon signed but keep it unlisted.

I'm sorry, could you provide a links or more details about it?

Thanks.

Comment 3

9 months ago
(In reply to SashaChernykhEmpressOfUniverse from comment #2)
> > The reasonsing for signing has been discussed at length elsewhere.
> 
> In official Mozilla sites I read only discussion in Mozilla blog, where all
> users criticized the solution —
> https://blog.mozilla.org/addons/2016/07/29/extension-signing-availability-of-
> unbranded-builds/ . Where I can read about reasons of solution from Mozilla
> developers?

It has come up and been discussed several times on the dev-addons list.  I don't have a specific message or thread to point you at but the archives are online here:
https://mail.mozilla.org/pipermail/dev-addons/

> > You can also run an unbranded build or you can get the addon signed but keep it unlisted.
> 
> I'm sorry, could you provide a links or more details about it?

for unbranded builds:
https://wiki.mozilla.org/Add-ons/Extension_Signing#Unbranded_Builds
(with more detail in the FAQ lower on that page)

Some details on unlisted addons are on MDN:
https://developer.mozilla.org/en-US/Add-ons/Distribution
(Reporter)

Comment 4

9 months ago
(In reply to Andrew Swan [:aswan] from comment #3)
> (In reply to SashaChernykhEmpressOfUniverse from comment #2)
> > > The reasonsing for signing has been discussed at length elsewhere.
> > 
> > In official Mozilla sites I read only discussion in Mozilla blog, where all
> > users criticized the solution —
> > https://blog.mozilla.org/addons/2016/07/29/extension-signing-availability-of-
> > unbranded-builds/ . Where I can read about reasons of solution from Mozilla
> > developers?
> 
> It has come up and been discussed several times on the dev-addons list.  I
> don't have a specific message or thread to point you at but the archives are
> online here:
> https://mail.mozilla.org/pipermail/dev-addons/
> 
> > > You can also run an unbranded build or you can get the addon signed but keep it unlisted.
> > 
> > I'm sorry, could you provide a links or more details about it?
> 
> for unbranded builds:
> https://wiki.mozilla.org/Add-ons/Extension_Signing#Unbranded_Builds
> (with more detail in the FAQ lower on that page)
> 
> Some details on unlisted addons are on MDN:
> https://developer.mozilla.org/en-US/Add-ons/Distribution

> I don't have a specific message or thread to point you at but the archives are online here:

I find only negative comments to this feature.

> for unbranded builds:

It turns out, I need to install another Firefox version, not stable. I don't want use Developer, Nigntly, ESR versions, Unbranded Builds and so on. I use stable Firefox.

> Some details on unlisted addons are on MDN:

I read in your link «Signing your add-on». I wrote in my bugreport, that addons, which I need to install, NOT MY addons: «I have no interest in doing this for a personal project, and no interest in distributing it in a store. I only want the add-on for personal use.»

---

Developer of GhostText addon wait review of his addon one month — https://github.com/GhostText/GhostText/issues/70#issuecomment-273711142 . Why users have to wait so long?

Thanks.
You need to log in before you can comment on or make changes to this bug.