Search button gets disabled at whitelabelglobe5staging.rmcnetwork.ca

RESOLVED INVALID

Status

Tech Evangelism
Desktop
RESOLVED INVALID
9 months ago
2 days ago

People

(Reporter: pargat.singh, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug)

Firefox 50
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webcompat])

Attachments

(1 attachment)

105.09 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
(Reporter)

Description

9 months ago
Created attachment 8828318 [details]
Steps to reproduce FF Issue.docx

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

https://whitelabelglobe5staging.rmcnetwork.ca/en/travel/flights.html#?c=search&tt=r

Please go to above site and when i click on search button it gets disabled. I can see disabled="disabled" gets added automatically.

This work perfectly in version 47.0.2 version.

Please see attached.


Actual results:

We have notice that in latest version some buttons are not working. 

Please see attached.


Expected results:

All button should have worked as they were working before and still works in other browser

Please see attached.

Comment 1

9 months ago
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2c9e3adfb02e5a2a0cc001dc4f703941db88a318&tochange=47cefafd3a2abdfdd1736a3b49239ddd4eb8593b
Blocks: 1241021
Component: Untriaged → DOM
Flags: needinfo?(dholbert)
Product: Firefox → Core
Mike, looks like this was broken by a webcompat fix (bug 1241021). Any chance you have cycles to investigate what's going wrong here?
Flags: needinfo?(dholbert) → needinfo?(miket)
Summary: FF Version 50.1.0 broke the site → Search button gets disabled at whitelabelglobe5staging.rmcnetwork.ca
Yep! Let me leave ni?, I have a good chunk of meeting-free time today/tomorrow to look at this (\o/)
Whiteboard: [webcompat][needsdiagnosis]
When I click on the button, I get the following message in the console:

Uncaught error handled:  {
    "errorLevel": 1,
    "href": "https://whitelabelglobe5staging.rmcnetwork.ca/en/travel/flights.html#?c=search&tt=r",
    "component": "flights",
    "controllers": "search",
    "errorMessage": "SecurityError: The operation is insecure.",
    "errorFile": "https://whitelabelglobe5staging.rmcnetwork.ca/etc/clientlibs/aimia/knockout/knockout.activity.min.js",
    "lineNumber": 19,
    "redirectedTo": "https://whitelabelglobe5staging.rmcnetwork.ca/en/travel/flights.html#?c=search&tt=r",
    "collectorId": "NotAvailable",
    "bookingSearchId": "NotAvailable"
}  common.js:6606:13

Makes me think of Bug 1314311...

So in that knockout.activity.mins.js file:

if (document.createElement("div").style.WebkitAnimationName !== undefined) {
    var g = {};
    b = function(j, n, k) {
        if (!g[n]) {
            var h = "spin" + n;
            var m = "@-webkit-keyframes " + h + " {";
            for (var l = 0; l < n; l++) {
                var q = Math.round(100000 / n * l) / 1000;
                var p = Math.round(100000 / n * (l + 1) - 1) / 1000;
                var o = "% { -webkit-transform:rotate(" + Math.round(360 / n * l) + "deg); }\n";
                m += q + o + p + o
            }
            m += "100% { -webkit-transform:rotate(100deg); }\n}";
            document.styleSheets[0].insertRule(m, 0);
            g[n] = h
        }
        j.css("-webkit-animation", g[n] + " " + k + "s linear infinite")
    }
} else {
...[snip]...
}

document.styleSheets[0] is "https://cdn.jsdelivr.net/jquery.slick/1.5.7/slick.css", which is a different origin, hence the insecure operation error. 

That turns out to be the exact some code from https://bugzilla.mozilla.org/show_bug.cgi?id=1248444#c3, so it's a safe bet that the origin of this idiom is:

* NETEYE Activity Indicator jQuery Plugin
* Copyright (c) 2010 NETEYE GmbH 

So, given the "staging" name in the URL... Pargat, would you have to be working on this site? You should be able to workaround this issue by appending a new stylesheet, rather than writing to the (non-same origin) existing one.
Flags: needinfo?(miket) → needinfo?(pargat.singh)
Blocks: 1314311
Whiteboard: [webcompat][needsdiagnosis] → [webcompat][needscontact]
Clarifying component here. Is there a timeout on closing these types of requests?
Component: DOM → Desktop
Product: Core → Tech Evangelism
Version: 50 Branch → Firefox 50
Andrew, not necessary.

Going to https://whitelabelglobe5staging.rmcnetwork.ca/en.html I do not see a search button.
Is it even a real site? Most of the anchors are empty. The name even contains staging.


Ah whois on rmcnetwork.ca
Registrant:
    Name:              AIMIA Proprietary Loyalty Canada Inc.


If I go to https://www.aimia.com/ There is a site which is working. 

Parta was it a site you were working on? A draft version?

I would close as invalid, given that https://www.aimia.com/ has a working site completely different.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 days ago
Resolution: --- → INVALID
Whiteboard: [webcompat][needscontact] → [webcompat]
You need to log in before you can comment on or make changes to this bug.