Closed Bug 1332305 Opened 3 years ago Closed 3 years ago

keyword lost after editing bookmark URL

Categories

(Firefox :: Bookmarks & History, defect)

39 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1150678

People

(Reporter: zilla, Unassigned)

References

Details

(Keywords: dataloss, dupeme, regression)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161213225121

Steps to reproduce:

I had a bookmark with a keyword "docbook" and the URL http://docbook.org/tdg5/en/html/%s.html (although I don't think those specifics matter).

I used Ctrl-B to open the bookmark sidebar and right-clicked on the bookmark, and chose Properties.
I updated the URL to http://tdg.docbook.org/tdg/5.0/%s.html and clicked save.




Actual results:

When trying to use the keyword search by entering "docbook literal" in the location bar I get a normal web search, not using the keyword.

Right-clicking on the bookmark again I see that the keyword field is now blank. Re-entering "docbook" and clicking Save again fixes it.

The problem is reproducable, every time I edit the bookmark URL and save it the keyword field gets lost. Editing the bookmark name and saving doesn't lose the keyword.


Expected results:

The keyword field should not have been erased when I changed the bookmark URL and clicked on Save.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Component: Untriaged → Bookmarks & History
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
Keywords: dataloss, dupeme
OS: Linux → All
Hardware: x86_64 → All
Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4d2d97b3ba34&tochange=b8e628af0b5c [2015-03-20, 2015-03-21]

Suspect:
Bug 1125113 - Change the keywords schema associating them with uris
Blocks: 1125113
Has Regression Range: --- → yes
Keywords: regression
Version: 50 Branch → 39 Branch
likely dupe of bug 1150678, fixed in 51.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150678
You need to log in before you can comment on or make changes to this bug.