bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

login page not recognized as such, no username/password collected



Passwords & Permissions
16 years ago
14 years ago


(Reporter: Rein Smedinga, Assigned: Stephen P. Morse)


Windows 2000

Firefox Tracking Flags

(Not tracked)




(3 attachments)



16 years ago
Password manager does not recognize above mentioned web site as a site with a

Therefore my loginname and password is not collected.

In earlier versions of Mozilla (propably back to 0.9.4 or something) this worked
and recent versions of Mozilla still recognized the page as such and filled in
the username and password until I destroyed my password-file. After that, the
password manager did not recognize the page and my username/password is not
stored anymore.

Current build: 2002031104

Comment 1

16 years ago
Reporter, are you sure that the site has not opted out of using password 
manager?  See bug 93776 for details.  And if that is the case, then bug 124065 
will provide a work-around for you.

Comment 2

16 years ago
As far as I can see (but I am not a professional in this) there is no opting out
of anything. I have included the source of the login page so you can check.

B.t.w. I do not understand how to work around, should I install extra things in
my Mozilla, or is there a setting somewhere I can change?

Comment 3

16 years ago
Created attachment 76171 [details]
source of login that password manager does not recognize as such

Comment 4

16 years ago
Clicking on your attachment results in:

   Not Found
   The requested URL /javascript/md5.js was not found on this server.
   Apache/1.3.19 Server at bugzilla.mozilla.org Port 80

Comment 5

16 years ago
Created attachment 76188 [details]
additional js-file for first attachment

Comment 6

16 years ago
Created attachment 76189 [details]
second additonal js-file for first attachment

Comment 7

16 years ago
I have added two necessary js-files. 
Please delete the string "/javascript/" twice in the first file.

In my opinion the javascripts never opt out the password manager.

Comment 8

16 years ago
the testcase worksforme with 062408 mozilla build on win2K. I cannot access the
original site though to test there. 
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
I have used version 2002070108 and the browser still does not recognize the
login to the site nestor.rug.nl

B.t.w. that site should be accessable from all over the world, using username
and password  gast/gast.
Resolution: WORKSFORME → ---

Comment 10

16 years ago
I too am not able to access your original site (http://nestor.rug.nl).  I get 
a message saying that cookies are not being accepted.  I noticed when I tried 
this under 4.x, I saw that the site actually does a redirect to another page 
that puts up the login form.  So I didn't get to check to see if the page prior 
to redirect does some browser sniffing and rejects mozilla.  In any case, that's 
a different bug.

As far as this bug is concerned, I looked at the source of the login page (using 
4.x since I couldn't even get that far with mozilla) and I see that the js on 
the page actually erases the password and instead stores an encrypted password 
in a hidden field.  This will fool the password manager since it rejects 
forms if the password is blank (see line 3997 in wallet.cpp).  By design the 
password manager attempts to recognize the most common login forms, but it can't 
recognize every one.

So even if I could get by the cookie problem, I'm pretty sure that this form 
will fail to trigger the password manager because of the blank password field.  
Therefore this bug report is invalid.
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.