Enable print_via_parent for Tier3 platforms

RESOLVED FIXED in Firefox 53

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jbeich, Assigned: jbeich)

Tracking

Trunk
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed, firefox54 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

2 years ago
XP_WIN + XP_MACOSX + XP_LINUX covers everything Tier1 atm. What's left are Darwin/X11, BSDs, Solaris using Gtk and iOS, the support for which is going to bitrot over time the farther they stray away from any of Tier1 platform.
Comment hidden (mozreview-request)
On said platforms, are they using our Fontconfig platform font list that is bound up with our GTK support? If so, then they are supported, and it's just a matter of flipping the pref. The only case that does not currently work is if using the gfxFT2FontList (currently only Android that I know of) does not have NativeFontResource implemented for it yet, so only that wouldn't work.

If said platforms are GTK then basically all we have to do is change this line:
https://dxr.mozilla.org/mozilla-central/source/modules/libpref/init/all.js?q=all.js%3A1112&redirect_type=direct#1112

Currently it is predicated on XP_LINUX, but that could thus be changed to MOZ_WIDGET_GTK, and we'd thus be done.
Comment on attachment 8828469 [details]
Bug 1332411 - Enable print_via_parent for Tier3 platforms.

We don't implement print_via_parent for all platforms yet, so we can't just blindly remove all the checking for setting the pref default. Correct way to do this for now would probably be checking for MOZ_WIDGET_GTK as suggested.
Attachment #8828469 - Flags: review?(lsalzman) → review-
Assignee

Comment 4

2 years ago
(In reply to Lee Salzman [:lsalzman] from comment #2)
> On said platforms, are they using our Fontconfig platform font list that is
> bound up with our GTK support?

Do you mean "monospace", "serif", "sans-serif" ? I don't think Firefox supports Gtk *without* fontconfig.

> The only case that does not currently work is if using the
> gfxFT2FontList (currently only Android that I know of) does not have
> NativeFontResource implemented for it yet, so only that wouldn't
> work.

Android defines XP_LINUX, so I'm not sure what you mean here.
(In reply to Jan Beich from comment #4)
> (In reply to Lee Salzman [:lsalzman] from comment #2)
> > On said platforms, are they using our Fontconfig platform font list that is
> > bound up with our GTK support?
> 
> Do you mean "monospace", "serif", "sans-serif" ? I don't think Firefox
> supports Gtk *without* fontconfig.
> 
> > The only case that does not currently work is if using the
> > gfxFT2FontList (currently only Android that I know of) does not have
> > NativeFontResource implemented for it yet, so only that wouldn't
> > work.
> 
> Android defines XP_LINUX, so I'm not sure what you mean here.

Then that would be an unfortunate accident. Since it does not actually work at all on Android, and by virtue of the fact we don't enable E10s there yet we avoided catastrophe for now.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Attachment #8828469 - Flags: review?(lsalzman) → review+

Comment 8

2 years ago
mozreview-review
Comment on attachment 8828469 [details]
Bug 1332411 - Enable print_via_parent for Tier3 platforms.

https://reviewboard.mozilla.org/r/105862/#review110680

If Lee is OK with this I have no objection.
Attachment #8828469 - Flags: review?(ted) → review+
Assignee: nobody → jbeich
Assignee

Updated

2 years ago
Keywords: checkin-needed

Comment 9

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a28293f9d514
Enable print_via_parent for Tier3 platforms. r=ted
Keywords: checkin-needed

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a28293f9d514
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Assignee

Comment 11

2 years ago
Comment on attachment 8828469 [details]
Bug 1332411 - Enable print_via_parent for Tier3 platforms.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1309205 regression on Android and feature parity with Linux on BSDs
[User impact if declined]: Printing to file on FreeBSD may fail with e10s enabled
[Is this code covered by automated tests?]: Unlikely
[Has the fix been verified in Nightly?]: Yes, by myself.
[Needs manual test from QE? If yes, steps to reproduce]: Probably not.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: For Tier1 only restores Android behavior to before bug 1309205 per comment 5.
[String changes made/needed]: None
Attachment #8828469 - Flags: approval-mozilla-aurora?
Comment on attachment 8828469 [details]
Bug 1332411 - Enable print_via_parent for Tier3 platforms.

Fix a potential printing issue on FreeBSD. Aurora53+.
Attachment #8828469 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.