Consider the adjustment of element dimension from the layout perspective.

RESOLVED DUPLICATE of bug 1293242

Status

()

Core
XP Toolkit/Widgets: XUL
RESOLVED DUPLICATE of bug 1293242
a year ago
11 months ago

People

(Reporter: seanlee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
AFAIK, Downloads Panel and AutoCompletePopup use JS to calculate the height and width then adjust the container to a fitting size based on the child elements. This kind of solutions do not work properly if there are some cases not handled well like these bugs:

bug 1292345 - Downloads panel didn't shrink to the fit height after all items are downloaded.
bug 1317882 - AutoComplete dropdown with Insecure Warning is not extended the correct height at first time opening
bug 1325695 - Wrapping width of the insecure login field warning doesn't reflect the <input> width sometimes

I wonder if there is a proper way to CSS properties or element attributes which are applied to both container and child elements to get the expected dimension, so we can avoid the calculation of the dimension of each element. IMHO, if min-height is given to the container, its height does not have to set manually when the children are removed.

Comment 1

a year ago
Fixing this for the Downloads Panel is dependent on bug 1293242. I'm not sure if the autocomplete popup is the same case, but lacking information I'm marking it as a dependency, because bug 1293242 might actually help.
Depends on: 1293242

Comment 2

11 months ago
This was mostly handled for the Downloads Panel in bug 1009116, even if we had to introduce a workaround. The remaining cases are likely all related to bug 1293242 and they have been worked around as well.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1293242
You need to log in before you can comment on or make changes to this bug.