Granting geolocation permission does not show in Control Center and does not persist properly

RESOLVED DUPLICATE of bug 1322785

Status

()

RESOLVED DUPLICATE of bug 1322785
2 years ago
2 years ago

People

(Reporter: pdol, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

(Whiteboard: [fxprivacy])

(Reporter)

Description

2 years ago
My Info: Win10, 53.0a1 (2017-01-14) (64-bit)

STR_1:
1. Open url [1]
2. Click on button "Get Location"
3. Click "Remember this decision"
4. Click "Allow Location Access"
5. Click on Control Center "i" icon
6. Close Control Center by clicking off of it
7. Click on button "Get Location" again (can be immediately or after reloading page)

AR:  Site gets geolocation, no geolocation permission displayed in Control Center, geolocation permission prompt displays again
ER:  Site gets geolocation, geolocation permission displayed in Control Center (with ability to revoke it), geolocation permission prompt does not display again (since remember this decision used)

[1] https://people-mozilla.org/~dolske/tmp/geoloc-new.html
It should work if you update your Nightly :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
Duplicate of bug: 1322785
(Reporter)

Comment 2

2 years ago
(In reply to Johann Hofmann [:johannh] from comment #1)
> It should work if you update your Nightly :)
> 
> *** This bug has been marked as a duplicate of bug 1322785 ***

Should have tried that first.  Works :)
You need to log in before you can comment on or make changes to this bug.