Closed Bug 1332544 Opened 5 years ago Closed 5 years ago

Replace use of mOwner with GetOwner() which provides more checks

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: jwwang, Assigned: jwwang)

References

Details

Attachments

(1 file)

Bug 1319900 shows an issue where mOwner somehow becomes a dangling pointer before Shutdown() is called. Bug 1326294 add some checks to diagnose the lifetime of the media element. However, most code in MediaDecoder.cpp still use mOwner directly which bypasses the checks we added in GetOwner(). We will replace use of mOwner with GetOwner() to get more debugging checks.
Assignee: nobody → jwwang
Priority: -- → P3
See Also: → 1319900
Attachment #8828651 - Flags: review?(gsquelart)
Comment on attachment 8828651 [details]
Bug 1332544 - replace use of mOwner with GetOwner() which provides more checks.

https://reviewboard.mozilla.org/r/105996/#review106930
Attachment #8828651 - Flags: review?(gsquelart) → review+
Thanks!
Pushed by jwwang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4c7d2394a2ad
replace use of mOwner with GetOwner() which provides more checks. r=gerald
https://hg.mozilla.org/mozilla-central/rev/4c7d2394a2ad
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Comment on attachment 8828651 [details]
Bug 1332544 - replace use of mOwner with GetOwner() which provides more checks.

Approval Request Comment
[Feature/Bug causing the regression]:1332544
[User impact if declined]: This is required to uplift bug 1333644 which is a workaround for UAF in bug 1326294.
[Is this code covered by automated tests?]:yes
[Has the fix been verified in Nightly?]:yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]:none
[Is the change risky?]:no
[Why is the change risky/not risky?]:This patch is as simple as replacing direct member access with a getter function.
[String changes made/needed]:none
Attachment #8828651 - Flags: approval-mozilla-aurora?
Comment on attachment 8828651 [details]
Bug 1332544 - replace use of mOwner with GetOwner() which provides more checks.

This patch is required to fix a crash - bug 1333644. Aurora53+.
Attachment #8828651 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1319790
You need to log in before you can comment on or make changes to this bug.