Duplicate top sites due to multiple redirects being introduced in history

REOPENED
Unassigned

Status

()

P5
normal
REOPENED
2 years ago
5 months ago

People

(Reporter: oana.horvath, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec+, firefox53 affected, firefox54 affected, firefox55 affected, firefox56 affected)

Details

(Whiteboard: [mobileAS])

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8828804 [details]
desktop_history.png

Environment: 
Device: LG G4(Android 6.0) & Lenovo A536 Android (4.4.2);
Build: Nightly 53.0a1 (2017-20-1);

Steps to reproduce:
1. On a clean profile, on Firefox desktop browser, type in a website address, without http://www. E.g: bbc.com, gmail.com.
2. Sign in with the same profile on an mobile device and sync.
3. Check the history records synced on the mobile device. 

Expected result:
The synced history should be the same on both mobile and desktop browsers. The redirects made to open the final page should be hidden.

Actual result:
Redirects as from http to https or from bbc.com to http://www.bbc.com, etc, are hidden in Firefox desktop, but shown in Fennec. These multiple urls that lead to the same page, create duplicated top sites.

Notes: Attached screenshots.
(Reporter)

Comment 1

2 years ago
Created attachment 8828805 [details]
Screenshot_2017-01-20-14-28-41.png
(Reporter)

Comment 2

2 years ago
Created attachment 8828806 [details]
Screenshot_2017-01-20-14-01-08.png
(Reporter)

Comment 3

2 years ago
Created attachment 8828807 [details]
Screenshot_2017-01-19-09-04-30.png
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1274424
Normally the newer bug is duped to the older bug. In the future please follow this practice.
tracking-fennec: --- → ?
status-firefox54: --- → affected
status-firefox55: --- → affected
status-firefox56: --- → affected
Duplicate of this bug: 1385651
Also, reproducible when sync is not performed.
Activity Stream will replace Top Site. So mark this as won't fix.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Comment 9

2 years ago
[traige@0816] Max, would you help remove the tracking-fennec? since this is WONTFIX? Tks.
Flags: needinfo?(max)
tracking-fennec: ? → ---

Comment 10

2 years ago
This isn't a WONTFIX. Activity Stream isn't changing the top sites algorithm much (just how things are pinned and displayed, IIUC), neither did our underlying data change much from which Top Sites are generated. Some de-duping work was done in Bug 1382332, but I don't expect it to help here. 

As described in Comment 1 (history synced from desktop), this might not be as relevant in practice due to us heavily de-prioritizing remote history. For synced desktop visits, the visit type might help us exclude these bogus visits from our calculations, if we don't do this already. On Fennec though, all visits are recorded with the same default type, unfortunately.

I'd expect this to still be a practical problem for any visits/redirects generated locally on the device, e.g. see Comment 7.

NI mcomella as he's working on this currently.
Flags: needinfo?(max) → needinfo?(michael.l.comella)
See Also: → bug 1382332

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(In reply to :Grisha Kruglov from comment #10)
> Activity Stream isn't changing the top sites algorithm much

This is true: Nevin & Taipei folks, if you see old top sites bugs with regard to the data (as opposed to the presentation), be sure to flag me!

> Some de-duping work was done in Bug 1382332, but I don't expect it to help here.

In that bug, I only:
- Dedupe "http" vs. "https" sites in highlights
- Dedupe multiple bookmarks making multiple top sites entries

While this bug looks like it's about:
- Dedupe "(www.)url" in top sites
- Dedupe "http(s)" in top sites
- (maybe) dedupe "news.google.com/#0" & "news.google.com"

Alternatively to ^: we can distinguish which visits are redirects and weight non-redirects higher in top sites

> I'd expect this to still be a practical problem for any visits/redirects
> generated locally on the device, e.g. see Comment 7.

Changed the bug title accordingly.

> NI mcomella as he's working on this currently.

Thanks for flagging me.

For what it's worth, I'd like to see how much this actually happens in the wild before we put in the effort to fix it. For new profiles, these sites appear in top sites but I don't think they'd be very prevalent for a used profile (so a new profile might be a little unpolished). Top sites reads from a Cursor directly so it's a pain to modify the data or skip entries.
tracking-fennec: --- → ?
Depends on: 1382332
Flags: needinfo?(michael.l.comella)
Summary: Duplicate top sites due to multiple redirects being introduced in history, syncing with desktop Firefox → Duplicate top sites due to multiple redirects being introduced in history
Whiteboard: [mobileAS]
Comment hidden (typo)
Maria thinks its important to make top sites look as good as possible but we recognize this is an existing issue - Aaron, how important do you think this is?

Roughly, my understanding of what needs to be changed issue is:
- If both www.<url> and <url> appear, we remove www.<url>
- If both http<url> and https<url> appear, we remove http<url>

There is also the case of "news.google.com/#0" & "news.google.com" appearing in top sites but I don't know that redirecting <url>/#anchor -> <url> is always the best case for the user (e.g. if I intentionally bookmark an anchor tag in the page, I'd never have that in my top sites).
tracking-fennec: ? → +
Priority: -- → P3
We prioritized this and no longer need UX feedback.
Flags: needinfo?(abenson)
All open Activity Stream bugs are moving from the whiteboard tag, "[mobileAS]", to the Firefox for Android component, "Activity Stream", so that I can keep better track of these bugs as the new triage owner; I will send out an email shortly with additional details, caveats, etc.
Component: Data Providers → Activity Stream
Duplicate of this bug: 1418657

Comment 17

a year ago
Hi guys, I got directed here from bug 1418657 which apparently is a duplicate (I'm not so sure).

While you are de-duplicating can you think about preventing

moz-extension://
https://addons.mozilla.org

from appearing in Fennec's History and Top Sites?

At the moment I get all kinds of junky entries. It's a particular problem if you use uBlock Origin or similar, every time you open the uBO dashboard you get a moz-extension://[big hex number] entry in History which isn't really very useful.

cheers now
(Reporter)

Updated

10 months ago
Duplicate of this bug: 777799
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: P3 → P5
You need to log in before you can comment on or make changes to this bug.