Closed Bug 133273 Opened 23 years ago Closed 23 years ago

URL field not linked after show_bug.cgi templatization

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

2.15
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: ddkilzer, Assigned: ddkilzer)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

The template uses bug.url but the URL is actually stored in
bug.bug_file_loc.  Template also includes use of arcane
'FILTER url'.  Patch coming shortly.
Target -> 2.16.  Keywords: patch, review, regression.
Assignee: myk → ddkilzer
Keywords: patch, regression, review
Target Milestone: --- → Bugzilla 2.16
Status: NEW → ASSIGNED
Attached patch Patch v.1 (obsolete) — Splinter Review
Change bug.url -> bug.bug_file_loc in template.
Bug 110012 is the original show_bug.cgi templatization patch.
Comment on attachment 75970 [details] [diff] [review]
Patch v.1

You'll need to put the "FILTER url" back :-)

Gerv
Attachment #75970 - Flags: review-
I believe 'FILTER url' was deprecated in favor of 'FILTER uri'.
I will upload another patch.

BTW, if bug.bug_file_loc has a 'FILTER uri', then shouldn't
bug.milestoneurl use one, too (like 173)?

            <a href="[% bug.milestoneurl %]">Target Milestone</a>:
Attached patch Patch v.2Splinter Review
Now with 'FILTER uri' added.
Attachment #75970 - Attachment is obsolete: true
Attachment #75996 - Flags: review+
Comment on attachment 75996 [details] [diff] [review]
Patch v.2

2xr=gerv. The answer to your question is "yes, probably :-)". 

File another bug? <ducks>

Gerv
Filed Bug 133372 regarding use of 'FILTER uri' on bug.milestoneurl.
Gerv, looks like you replaced the second occurrence of bug.url, but not the one
at the IF:

<         [% IF bug.url %]
---
>         [% IF bug.bug_file_loc %]

Is there a bug somewhere about renaming the bug_file_loc to something
reasonable?
Should this bug be marked RESOLVED DUPLICATE of Bug 133425?
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: