Increased "Secure Connection Failed" errors

RESOLVED INVALID

Status

()

Core
Networking
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: alex_mayorga, Assigned: bagder)

Tracking

({nightly-community})

53 Branch
x86_64
Windows 7
nightly-community
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

(Whiteboard: [necko-active])

Attachments

(2 attachments)

1.08 MB, application/x-zip-compressed
Details
3.79 MB, text/plain
Details
(Reporter)

Description

a year ago
¡Hola!

Over the past week or so, I've seen a large increase on these errors while navigating:

"Secure Connection Failed

The connection to the server was reset while the page was loading."

I have to press F5 or even Ctrl+F5 multiple times before pages load.

This is not a problem on IE nor Chrome.

This is a problem on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 ID:20170120030214 CSet: aa3e49299a3aa5cb0db570532e3df9e75d30c2d1

I've collected a networking log, kindly let me know who to send it to.

¡Gracias!
Alex
(Reporter)

Comment 1

a year ago
¡Hola!

Lots of these as well:

"The connection was reset

The connection to the server was reset while the page was loading."

¡Gracias!
Alex
can you attach the log to this bug?
Whiteboard: [necko-next]
(Reporter)

Comment 3

a year ago
¡Hola Patrick!

These have morphed into SSL_ERROR_RX_RECORD_TOO_LONG now on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0 ID:20170124030205 CSet: 8ff550409e1d1f8b54f6f7f115545dbef857be0b

The log is 14 MB and the mail server doesn't let me send that much data.

Anything I should grep for?

¡Gracias!
Alex
Flags: needinfo?(mcmanus)
TOO_LONG is generally the error you get when you receive plaintext but were anticipating TLS. (i.e. when http:// content is returned for an https:// request). Can you maybe confirm that by looking at wireshark or uploading a wireshark packet capture.

As far as uploading things larger than bugzilla will attach.. the usual approaches are zip and/or uploading it to a free cloud service (like box or google drive) with a public link in the bug report.
Flags: needinfo?(mcmanus)
(Reporter)

Comment 5

a year ago
Created attachment 8830363 [details]
log.txt-main.zip

¡Hola Patrick!

Looked for the message mentioned and came back empty handed.

Luckily, it seems that the log zips rather nicely.

Please check and let me know of your findings.

¡Gracias!
Alex
Flags: needinfo?(mcmanus)
daniel, do you want to take a look?
Flags: needinfo?(mcmanus) → needinfo?(daniel)
(Assignee)

Comment 7

a year ago
Hi Alex!

That log does a number of HTTP requests, do you remember any specific host that caused the problem? (there's no exact error for record too long in there so I need a little guidance to spot where the error is known to have happened)

In general, you say that you see this error more often than before. Is there are particular host that you experience is a fair example site to use that gives you these problems at a high frequency (and that possibly didn't use to do that in the past to your knowledge) ?

Do you experience that these errors can happen on *all* hosts or that they are more likely to occur on some sites?
Assignee: nobody → daniel
Flags: needinfo?(daniel)
Whiteboard: [necko-next] → [necko-active]
(Reporter)

Comment 8

a year ago
Created attachment 8834449 [details]
networking log

¡Hola Daniel!

The error is seen in most of HTTPS connections, i.e. to this very bug.

I have to refresh <F5> or "hard refresh" <Ctrl>+<F5> multiple times for HTTPS sites to load.

One common ocurrence is trying to search form the URL bar, which I've set to search in https://www.bing.com/

Attached is a log of trying to search for "prueba" which eventually loaded https://www.bing.com/search?q=prueba&pc=MOZI&form=MOZLBR but showed "Secure Connection Failed" a few times prior to a successful load.

Hope this all made sense, if not I-m happy to clarify.

¡Gracias!
Alex
Flags: needinfo?(daniel)
(Assignee)

Comment 9

a year ago
I've now played with Nightly (now number 54) on Windows 7 as well as on Linux for several days and reloaded and tested many HTTPS sites, but I cannot reproduce this problem. Do you happen to know when your problems started? Could you try to mozregression or other means to bisect down to some sort of revision interval when this problem was introduced? (assuming it isn't present in an older version)
Flags: needinfo?(daniel) → needinfo?(alex_mayorga)
(Reporter)

Comment 10

a year ago
¡Hola Daniel!

Let's chalk this one up to strange things that happen behind the corporate proxy of the corporation that signs my paychecks...

¡Gracias!
Alex
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(alex_mayorga)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.