Open Bug 1332754 Opened 3 years ago Updated 7 months ago

Move messaging and logic into action creators

Categories

(DevTools :: Responsive Design Mode, defect, P3)

defect

Tracking

(firefox53 affected)

REOPENED
Tracking Status
firefox53 --- affected

People

(Reporter: jryans, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rdm-v2])

Currently we have various function in app.js that apply device properties by posting messages to the manager and may also apply some logic.

In idiomatic Redux AIUI, it is more natural for this to be done in the action creator instead.
Product: Firefox → DevTools
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1248619
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Blocks: rdm-ux
You need to log in before you can comment on or make changes to this bug.