Closed Bug 1332839 Opened 3 years ago Closed 3 years ago

Intermittent toolkit/content/tests/chrome/test_arrowpanel.xul | state is open after transitionend - got "showing", expected "open"

Categories

(Toolkit :: XUL Widgets, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox52 --- wontfix
firefox-esr52 --- fixed
firefox53 --- fixed
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: enndeakin)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(1 file)

I have hacked on this and tried to figure out what is going on with no luck.  A lot of retriggers doesn't yield anything conclusive:
https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-searchStr=osx%20debug%20mochitest-chrome-3&tochange=bc2f8a0c7d9a6aa5d683b1826c6c2d40c4d7ef48&fromchange=b80052cdc2e156d46a362a924d7c066228a57ad8&selectedJob=83118640

The problem is this has become much more frequent in the last few days:
https://brasstacks.mozilla.com/orangefactor/index.html?display=Bug&bugid=1332839&startday=2017-03-03&endday=2017-03-10&tree=trunk

I will triage this more next week when there is more data and I have time to look at the failure a bit more
Flags: needinfo?(jmaher)
Whiteboard: [stockwell needswork]
looking into this more, I see this failing on osx debug tests as the only failure mode, and here is info from a log[0]:

23:30:01     INFO - TEST-START | toolkit/content/tests/chrome/test_arrowpanel.xul
23:30:02     INFO - GECKO(3082) | ++DOMWINDOW == 19 (0x11caf6800) [pid = 3082] [serial = 19] [outer = 0x1274b5000]
23:30:02     INFO - GECKO(3082) | ++DOCSHELL 0x125647800 == 7 [pid = 3082] [id = {531746a2-d376-ec4c-9f98-e2866f827722}]
23:30:02     INFO - GECKO(3082) | ++DOMWINDOW == 20 (0x12938a400) [pid = 3082] [serial = 20] [outer = 0x0]
23:30:02     INFO - GECKO(3082) | ++DOMWINDOW == 21 (0x12938f800) [pid = 3082] [serial = 21] [outer = 0x12938a400]
23:30:03     INFO - GECKO(3082) | [3082] WARNING: ENSURE_TRUE(weakFrame.IsAlive()) failed: file /home/worker/workspace/build/src/layout/xul/nsXULPopupManager.cpp, line 1176
23:30:05     INFO - TEST-INFO | started process screencapture
23:30:05     INFO - TEST-INFO | screencapture: exit 0
23:30:05     INFO - <snipped 336 output lines - if you need more context, please use SimpleTest.requestCompleteLog() in your test>
23:30:05     INFO - Buffered messages logged at 23:30:04
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is left 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on bottom 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is right 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on bottom 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is left 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on bottom 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is right 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on bottom 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is right 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on bottom 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is left 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on bottom 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is above 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is below 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is above 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on left  
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is below 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on left  
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - Buffered messages logged at 23:30:05
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is above 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is below 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is right 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on top 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel content is left 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchored on bottom 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | anchor 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel hidden 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow pack 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel alignmentPosition 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | big panel height 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | state is showing 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | state is showing during transitionend 
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | popupshown not fired yet 
23:30:05     INFO - Buffered messages finished
23:30:05     INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/chrome/test_arrowpanel.xul | state is open after transitionend - got "showing", expected "open"
23:30:05     INFO - SimpleTest.is@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:310:5
23:30:05     INFO - transitionEnded@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:190:9
23:30:05     INFO - EventListener.handleEvent*nextTest@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:201:5
23:30:05     INFO - onpopuphidden@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:1:1
23:30:05     INFO - hidePopup@chrome://global/content/bindings/popup.xml:137:13
23:30:05     INFO - checkBigPanel@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:319:3
23:30:05     INFO - onpopupshown@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:1:1
23:30:05     INFO - Not taking screenshot here: see the one that was previously logged
23:30:05     INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/chrome/test_arrowpanel.xul | popupshown now fired 
23:30:05     INFO - transitionEnded@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:191:9
23:30:05     INFO - EventListener.handleEvent*nextTest@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:201:5
23:30:05     INFO - onpopuphidden@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:1:1
23:30:05     INFO - hidePopup@chrome://global/content/bindings/popup.xml:137:13
23:30:05     INFO - checkBigPanel@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:319:3
23:30:05     INFO - onpopupshown@chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_arrowpanel.xul:1:1
23:30:05     INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | animated popup not hidden yet 
23:30:05     INFO - GECKO(3082) | MEMORY STAT | vsize 4288MB | residentFast 334MB | heapAllocated 100MB
23:30:05     INFO - TEST-OK | toolkit/content/tests/chrome/test_arrowpanel.xul | took 3716ms



and the related screenshot:
http://mozilla-releng-blobs.s3.amazonaws.com/blobs/autoland/sha512/d6d4df3a29c6a8f07e355f39e7af925328bd7638599c3bde69ac54c5667685effd7beeeddbd1a03b35625baeaecf50c33b2b9c80bba5ed8f0cb111d8f37c8bed

this is still failing at a consistent rate, I don't see this spiking high, but it seems to happen frequently enough.

Neil, can you take a look at why this is happening and work to fix this or consider disabling it on osx debug?  


[0] https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-macosx64-debug/autoland_yosemite_r7-debug_test-mochitest-chrome-3-bm136-tests1-macosx-build139.txt.gz
Flags: needinfo?(jmaher) → needinfo?(enndeakin)
It looks like an additional transitionend event is firing?

We can at least make the test a bit more robust and see if this fixes the issue.
Flags: needinfo?(enndeakin)
Attachment #8847167 - Flags: review?(felipc)
Attachment #8847167 - Flags: review?(felipc) → review+
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/91da71f8f19c
make transition checking more robust in this test, r=felipe
Whiteboard: [stockwell needswork] → [stockwell fixed]
https://hg.mozilla.org/mozilla-central/rev/91da71f8f19c
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Assignee: nobody → enndeakin
You need to log in before you can comment on or make changes to this bug.