[RFE} What are the Portable profile requirements

RESOLVED WORKSFORME

Status

Core Graveyard
Profile: BackEnd
--
enhancement
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Chris Lee, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The profile needs to be segmented to allow for portability.
Computer specific segment that deals with proxy settings, outgoing mail servers
and the like.
User specific data segment which may or may not include the cach as per user
request.
Profile manager also needs to be able to read a list of available profiles from
a server.

Example of situation:
My home PC has proxy my work PC does not, at work I use the exchange server as
an smtp relay at home I use my ISP, moving from one to another requires constant
modification of settings.

Comment 1

16 years ago
Bug 12911 is at least somewhat related to this. It concerns making paths
specified in the profile relative instead of absolute. I'm pretty sure this
should be all platforms, all OS's, too.
I really like the idea of separating the profile into machine-specific and
non-machine-specific sections. There could also be an OS-specific section as
well, although this would just as easily be considered part of the machine-specific.

Comment 2

16 years ago
Resolving as invalid. The bug description is not specific enough. A programmer
would not know how to solve the problem. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

16 years ago
This bug is a RFE and requires quite a bit of research by the relevent sections
of the mozilla project before being programmed.
As it needs to be refined to a point of being usefull to a programmer, maybe
this should be a bug to refine the requirements.
Changing the sumary and re-opening.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Portable profile requirements → What are the Portable profile requirements
(Reporter)

Comment 4

16 years ago
As a step towards refinement I see a few sections of Profile that need to be
separate but dont claim this to be a difinitive list or practicaly achivable:
1: System segment (contains skin and Icons for programm before mozila is started
and has acces to user skin, contains pre-user quicklaunch settings - allows for
desktop integration)
2: User Preferences (contains user prefs)
3: Network Settings (proxies etc.)
4: Bookmarks
5: History
6: Cache
7: Mail (Mail folders)
8: Mail accounts (Server send and receive settings)
9: linked profiles (conatins information on how to link parts of multiple
profiles, eg. network settings from file:///mydocs/user1/network mail from
file:///mydocs/user1/mail and http://myhomeserver.com/user2/mail and so on)

Hope that helps define it a bit more.
But as I say it still needs a lot of refinement and discussion before it is coded.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: What are the Portable profile requirements → [RFE} What are the Portable profile requirements

Comment 5

15 years ago
My 2c worth:
I think that first step of portability should be ability to easily move the
profile around on the same system (without the need to manually edit files who
happen to have different standards of path coding - at least in the Windows
version). Second step would be ability to use _same_ profile on the _same_
machine from _same_ files but from two different operating systems.
 
That is the problem I have right now - I have Linux and XP on the same machine.
For various reasons I have to have them both - now because I use Mozilla
exclusively for my e-mails and I can't get to my e-mails half of the time. I
think about a way of getting around it (like creating a script that would swap
config files in a shared profile each time I boot and close Linux), but it
should be much simpler than that. Profile should be divided into two parts -
system dependent setting of file paths (that should be it on the same computer)
and everything else that could be kept in a directory on a partition visibile to
all OS-es on the same machine.
QA Contact: ktrina → profile-manager-backend

Comment 6

5 years ago
We currently separate the "normal" profile from the "local" one (for windows roaming/local) and because of roaming profiles are relocatable. I don't think there's anything left to track here.
Status: NEW → RESOLVED
Last Resolved: 16 years ago5 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.