Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Popup to ask permissions for notifications (or other things) doesn't hide when focusing other parts of the UI or even other programs

RESOLVED DUPLICATE of bug 1109868

Status

()

Firefox
Site Identity and Permission Panels
RESOLVED DUPLICATE of bug 1109868
6 months ago
5 months ago

People

(Reporter: smaug, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox53- affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
Created attachment 8829160 [details]
screenshot

The popup should definitely hide automatically when other programs are focused. Right now it stays on top. 

But it should be also hidden when user focus some other part of the browser UI.
Like, right now if menu->open new window is clicked, the popup stays on top of the new totally unrelated window.

And user shouldn't need to say anything, no need to give or deny permission.
(Reporter)

Comment 1

6 months ago
And apparently ESC hides the popup but also makes the reload of the page to not ask the permission again.
Component: General → Site Identity and Permission Panels
(Reporter)

Comment 2

6 months ago
I never said yes or no to the popup in https://developer.mozilla.org/en-US/docs/Web/API/Notifications_API/Using_the_Notifications_API but reloading that page doesn't now ask the permission again. 
Yet Page info says "Receive Notifications: [x] Use default, Always ask"
(Reporter)

Comment 3

6 months ago
[Tracking Requested - why for this release]:
Permission popup is broken in many ways
status-firefox53: --- → affected
tracking-firefox53: --- → ?
Thanks for reporting, what you're experiencing is an unfortunate combination of a couple of issues we have not yet resolved. 
Bug 1320361 and Bug 1109868 are likely responsible for the issues described in comment 0. Comment 1 is expected behavior since the dialog is now modal. Comment 2 is caused by that MDN page using an iframe to show the notifications. Iframe support is currently being worked on in Bug 1330559 and bug 1224453, but considered out of scope for the initial release of the new permission prompts.

I have to say that your case makes me feel that this is really something we should rather fix sooner than later and try to uplift to 53, to not get an inconsistent user experience. Thanks again for reporting your troubles with the new system.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1109868
tracking-firefox53: ? → -
You need to log in before you can comment on or make changes to this bug.