Shutting off buildbot nighties shut off periodicupdates

VERIFIED FIXED

Status

defect
--
blocker
VERIFIED FIXED
3 years ago
Last year

People

(Reporter: philor, Assigned: kmoir)

Tracking

({regression})

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53+ fixed)

Details

Attachments

(3 attachments, 3 obsolete attachments)

As attachment 8827707 [details] says, shutting off buildbot nightlies also shut off the periodicupdate builder. Since the expiration on the last update that landed is April 26th, and 53 doesn't get replaced until June 13th, and we only do HPKP updates on aurora, not on beta/release, we have six weeks to get updates going on aurora.
[Tracking Requested - why for this release]:
If we don't fix it (or manually land an update to the expiration), HPKP will be broken two weeks into the 53 release lifespan.
Assignee: nobody → kmoir
Tracking 53+ to prevent brokenness.
So renabling them in buildbot is problematic because I haven't found a way to enable the periodic builds without renabling the nightly ones as well.  I think I'm going to enable them in tc via the new work for cron jobs in bug 1252948.
Posted patch bug1332930bb.patch (obsolete) — Splinter Review
wip buildbot patch

Fixing this is very difficult because the way the build dependencies work. I can't seem to leave the file update builder there while removing the generic builder
Posted patch bug1332930bcustom.patch (obsolete) — Splinter Review
(build6)[kmoir@dev-master2.bb.releng.use1.mozilla.com build6]$ diff old new
72a73,74
> Linux x86-64 mozilla-central build SigningScriptFactory
> Linux x86-64 mozilla-central periodic file update ScriptFactory
120a123,124
> Linux x86-64 mozilla-aurora build SigningScriptFactory
> Linux x86-64 mozilla-aurora periodic file update ScriptFactory

still need to remove the  build SigningScriptFactory for the branches
I tried taking a look, but

* I was unsuccessful in getting a buildbot env installed on my mac laptop, then
* I tried creating a buildbot centos docker image https://github.com/escapewindow/bbdocker but am currently stymied by pycrypto and pyOpenSSL not finding -lpython2.7 .

Rather than sink more hours into shaving the yak of reproducing the buildbot builder lists, I'm going to hazard a guess you're going to need one of these ugly |if| blocks to delete the generic builder: https://hg.mozilla.org/build/buildbot-configs/file/tip/mozilla/config.py#l2698
Thanks Aki, I will take another look
Attachment #8830065 - Attachment is obsolete: true
Attachment #8830066 - Attachment is obsolete: true
Posted patch bug1332930.patch (obsolete) — Splinter Review
builder diff 

72a73
> Linux x86-64 mozilla-central periodic file update ScriptFactory
120a122
> Linux x86-64 mozilla-aurora periodic file update ScriptFactory
Attachment #8830772 - Flags: review?(aki)
Comment on attachment 8830772 [details] [diff] [review]
bug1332930.patch

Blame/annotate will show people why this block is here, but it might be nice to add a comment to the |else:| block to say this is to keep periodicupdates.

Good work, thanks!  These if blocks aren't pretty, but they're part of moving off buildbot.  At some point we'll be able to get rid of these config files altogether.
Attachment #8830772 - Flags: review?(aki) → review+
Comment on attachment 8830772 [details] [diff] [review]
bug1332930.patch

caused the tests to fail
Attachment #8830772 - Attachment is obsolete: true
landed and merged to production, tests pass
Attachment #8830838 - Flags: checked-in+
verified the builder exists here
http://buildbot-master70.bb.releng.use1.mozilla.com:8001/builders
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Either we were astonishingly unlucky, getting a bad URL from the taskcluster index for the lastest build on both mozilla-central and mozilla-aurora, or the change to TC builds also broke that part of periodicupdates, since both runs this morning failed by getting a 404 URL for the builds.
Whomever is around first gets to review :)
We're not finding the artifacts because they're not pretty named: https://tools.taskcluster.net/task-inspector/#S_1gifVoSVyRo8JXHmyfuA/0
I'm guessing this patch will fix, but I'm not 100% sure.
Attachment #8831313 - Flags: review?(nthomas)
Attachment #8831313 - Flags: review?(kmoir)
Attachment #8831313 - Flags: review?(coop)
Comment on attachment 8831313 [details] [diff] [review]
fix_periodic.diff

lgtm
Attachment #8831313 - Flags: review?(nthomas) → review+
Attachment #8831313 - Flags: review?(kmoir)
Attachment #8831313 - Flags: review?(coop)
Attachment #8831444 - Flags: review?(rail)
Attachment #8831444 - Flags: review?(rail) → review+
Total victory.
Status: RESOLVED → VERIFIED
Attachment #8831444 - Flags: review?
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.