Crash in js::jit::DoTypeUpdateFallback

RESOLVED FIXED in Firefox 53

Status

()

P1
critical
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

Trunk
mozilla53
Unspecified
Android
crash
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox52 unaffected, firefox53- fixed)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-8cddb788-d377-45a3-aa50-ba7852170122.
=============================================================

Seen while looking at trunk crashes, started with 20170119222831 build: http://bit.ly/2kh3hgR.


one comment: "I just opened a private tab and put the phone in landscape."

Possible regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a5253dce8b67c2248d7b92ef664a6dd6664e7609&tochange=a3978751f45108ff1ae002ecebdc0fa23fc52b84
Regression from bug 1326067 part 2, should have been fixed by bug 1326067 part 5.
#1 crash in Nightly 20170120225350, with 19 occurrences. No Nightly builds have been made for Android since then, as far as I can tell, so no confirmation yet that it's been fixed.
(In reply to Nicholas Nethercote [:njn] from comment #2)
> #1 crash in Nightly 20170120225350, with 19 occurrences. No Nightly builds
> have been made for Android since then, as far as I can tell, so no
> confirmation yet that it's been fixed.

Just to add date (on why no nightlies), last we [releng] enabled taskcluster-generated nightlies. That includes android. We didn't enable the automatic scheduling of them until today (today's was a manual trigger, tomorrows should trigger automatically).

The first taskcluster nightlies are before the first crash date, so is unlikely to be a taskcluster specific issue involved in this bug.
Component: JavaScript Engine → JavaScript Engine: JIT
Blocks: 1326067
[Tracking Requested - why for this release]: Nightly Fennec top crash.
status-firefox52: --- → unaffected
status-firefox-esr45: --- → unaffected
tracking-firefox53: --- → ?
Tracking 53+ for this top nightly crash.
tracking-firefox53: ? → +
Priority: -- → P1
This is no longer very high volume so I'm dropping the tracking flag.
tracking-firefox53: + → -
This spike was both caused and fixed by bug 1326067 (see comment 1).
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.