Closed Bug 1332969 Opened 3 years ago Closed 3 years ago

stylo: several tests crash with "panicked at 'A device flush was pending'"

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox53 --- affected

People

(Reporter: xidorn, Assigned: emilio)

References

Details

Attachments

(1 file)

41 bytes, text/x-github-pull-request
Details | Review
To reproduce, execute:
> ./mach mochitest --disable-e10s layout/style/test/test_bug798843_pref.html

It crashes with
thread '<unnamed>' panicked at 'A device flush was pending', C:\mozilla-source\stylo\servo\components\style\gecko\data.rs:139

RUST_BACKTRACE=1 doesn't give me any further stack info.
layout/style/test/test_bug798843_pref.html
layout/style/test/test_dont_use_document_colors.html
layout/style/test/test_moz_device_pixel_ratio.html
layout/style/test/test_pixel_lengths.html
layout/style/test/test_unprefixing_service.html
layout/style/test/test_unprefixing_service_prefs.html
Summary: stylo: test_bug798843_pref.html crashes with "panicked at 'A device flush was pending'" → stylo: several tests crash with "panicked at 'A device flush was pending'"
Looks like this assertion was added recently in bug 1331213.
Flags: needinfo?(emilio+bugs)
Well, the idea with that assertion was to catch the different places where we don't flush stuff where we should, but we don't, so it's doing its job :).

I think those are all testing prefs or media queries that should make us rebuild all style data, but we're not doing that on time.

Should be a straightforward patch, will write it when I come from class if I have the time.
Attached file Patch
Assignee: nobody → emilio+bugs
Flags: needinfo?(emilio+bugs)
Verified that this has been fixed.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.