No dashes added before signature in "reply on top" if signature is placed after reply and before quote (bug or feature?)

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
10 months ago
10 months ago

People

(Reporter: David McDivitt, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

Create new email. The reply to an email.


Actual results:

For the new email, dash-dash and CR at the beginning of the sig.
For the reply it is not.


Expected results:

Sigs for both, new and replies, should be handled the same way.

I want the dash-dash CR in my sig, since it is still an internet standard. The sig saved in account settings has that. The sig must contain this if it will appear in replies. But new emails add that automatically. The result is I must always delete the dash-dash CR from the sig when doing new emails. It is a nuisance. Thunderbird could be coded to examine the sig for new emails and not insert if already present in the sig.

See issue 229044 where it says this is resolved, but it is not resolved. I've had this nuisance several years and would like it to go away.

My version is 45.6.0 for help/about, but I don't see that in the bug report dropdown, or do not know how to interporet.
What does the signature contain exactly? Does it include the --? So:

==============
--
David McDivitt
david@ss.com
==============
(without the =====)

You shouldn't have the -- in the signature itself, since TB automatically adds that. Just make sure the preference mail.identity.default.suppress_signature_separator is set it false (default) so the automatic -- separator is not suppressed.

It's added automatically in new message and replies.
Version: unspecified → 45 Branch
(Reporter)

Comment 2

10 months ago
The setting "mail.identity.default.suppress_signature_separator" was false. If I remove the -- from the sig, no -- is inserted in the sig on replies.

The setting "mail.identity.default.suppress_signature_separator" only applies to new emails. It has no effect on replies.

The setting does work for me. I set it to true and left the -- in my sig. Now the sig appears the same for new emails and replies and is exactly what I want.

This may still be a bug. I would think the setting should apply to new emails and replies, but it does not. Because I got what I want, I don't care.

Thanks for telling me about the setting. You made me very happy!
(In reply to David McDivitt from comment #2)
> The setting "mail.identity.default.suppress_signature_separator" was false.
> If I remove the -- from the sig, no -- is inserted in the sig on replies.
As I said, -- is automatically inserted, so the signature should not have the --.
I've just tried it in TB 45.6 and it works fine for me. If that doesn't work for you, then you have an add-on installed, that interferes, and you should take the issue to the add-on author.

To temporarily run without add-ons, use "Restart with Add-ons Disabled ..." from the Help menu.
(In reply to David McDivitt from comment #2)
> Thanks for telling me about the setting. You made me very happy!
So please make me happy by telling me whether the -- is placed in safe-mode (add-ons disabled) for you as is should.
Flags: needinfo?(david)
(Reporter)

Comment 5

10 months ago
OK, I set "mail.identity.default.suppress_signature_separator" to false, restarted to insure it was false, and left --CR at the beginning or my sig. Then I restarted in safe mode using help, restart with add-ons disabled. I did a new email. There was --CR--CR at the top of the sig, meaning an extra set of dashes was inserted. I did a reply. There was --CR at the top of the sig, meaning an extra set of dashes was not inserted.

The way I see it, --CR is never inserted for replies, and the config switch setting only no difference for replies.

If I set the switch to true, new emails function the same as replies.
(Reporter)

Comment 6

10 months ago
The way I see it, --CR is never inserted for replies, and the config switch setting makes no difference for replies.
I finally remembered what's happening here since I've worked in this area before and I remember the -- not being place automatically.

In your account setup there in "Composition & Addressing" you can determine whether your reply is going after the quote or in top of it.

If you put the reply below the quote, you get the --.
If you put the reply above the quote, you can put the signature either between the reply and the quote or at the end. When the signature is placed between the reply and the quote, no dashes are added. Crazy, huh?

That's been like this "traditionally" and I don't know why. Code is here:
https://dxr.mozilla.org/comm-central/rev/60e4648f97111ce2d5cc2fd46b49c00fdfeda06a/mailnews/compose/src/nsMsgCompose.cpp#4628

if ((reply_on_top != 1 || sig_bottom || !aQuoted)

In your case reply_on_top==1 (true), sig_bottom=false and aQuote==true sine it's a reply. And voilĂ , no dashes added in the reply. Crazy.

I've only been working in the project for two years, so I don't know all the answers yet. Let's ask someone who might know.

Question: If you reply on top and place the signature below the reply and above the quote, you get no dashes added. Why is that?
Flags: needinfo?(philip.chee)
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(iann_bugzilla)
Flags: needinfo?(david)
Summary: dash-dash automatically added in sig differently, new emails vs reply → No dashes added before signature in "reply on top" if signature is placed after reply and before quote (bug or feature?)

Comment 8

10 months ago
(In reply to Jorg K (GMT+1) from comment #7)
> Question: If you reply on top and place the signature below the reply and
> above the quote, you get no dashes added. Why is that?

Because everything below "-- \n" is considered part of the signature. Why you reply on top the quoted text would be in the signature. (And signatures are stripped, styled differently etc.)
Flags: needinfo?(mkmelin+mozilla)

Comment 9

10 months ago
s/Why/When/
(In reply to Magnus Melin from comment #8)
> Because everything below "-- \n" is considered part of the signature.
Hmm.

> When you reply on top the quoted text would be in the signature.
> (And signatures are stripped, styled differently etc.)
Signatures are stripped due to the <div/pre class="moz-signature"> they live in, not based on the dashes.

Anyway, as I said earlier, this has been the behaviour of the system forever and if I change it now, I'll cause an upheaval.

So David, use the setting to suppress the dashes and add your own.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(philip.chee)
Flags: needinfo?(iann_bugzilla)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.