halifax.es - Bad browser sniffing, use of <layer> tag, can't enter site

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bank][deny][bug248549notfixed], URL)

(Reporter)

Description

17 years ago
http://www.halifax.es/ uses bad browser detection and blocks access to gecko
broser :
var IE4 = (document.all) ? 1 : 0;

var NN4 = (document.layers) ? 1 : 0; 



function precargaespanol()

{

	if(IE4 || NN4)

	{

	var centrado = (screen.width/2)-400;

	self.name='Yes';

	alto = (IE4) ? 475 : 505;

	todo=eval("window.open('index2.html','halifax','toolbar=0,location=1,titlebar=no,menubar=1,directories=no,status=no,scrollbars=no,resizable=no,copyhistory=no,width=790,height=" + alto + ",top=0,left=" + centrado + "')");

	}

	else

	{alert('página optimizada para navegadores 4');return;}

}

If you bypass the home page and enter http://www.halifax.es/index2.html

you will be sent bad DHTML code using deprecated NS4 <layer> tags.


Contact email is : halifax@halifax.es
(Reporter)

Updated

17 years ago
Whiteboard: [eurocontest] [bank]

Comment 1

17 years ago
Adding [deny] in the status whiteboard. Setting P2.
Confirming with 0.9.9 on WinXP
(Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311)

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Whiteboard: [eurocontest] [bank] → [eurocontest] [bank][deny]
(Reporter)

Comment 2

17 years ago
Sent Spanish Tech Evangelism letter to halifax@halifax.es
Summary: www.halifax.es - Bad browser sniffing, use of <layer> tag, can't enter site → halifax.es - Bad browser sniffing, use of <layer> tag, can't enter site

Comment 3

16 years ago
tech evang june 2003 reorg
Assignee: nitot → spanish
Component: Europe: West → Spanish
QA Contact: z-caillon-obsolete2 → spanish
(Reporter)

Updated

15 years ago
Whiteboard: [eurocontest] [bank][deny] → [bank][deny][bug248549notfixed]

Comment 4

13 years ago
one of the best references/recommendations I've found for encouraging financial institutions to support firefox is located at bankers on-line web site 

http://www.bankersonline.com/security/security_browserthreat070204.html 

It was written in 2004 during the download.ject attack, but much of it still applies today.  This is a good link to send when contacting banks.
This looks like it's working fairly normally in both Firefox 2 and Camino-trunk, in that I can go to the home page and click through to (and use, to the extent that I don't have an account) the English version of the site without any errors or busted rendering. Fixed?
(Reporter)

Comment 6

12 years ago
site redesigned, WFM now
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.