Closed Bug 1333154 Opened 3 years ago Closed 3 years ago

Permafailing on merge to beta type-per-property.html | clear uses discrete animation when animating between 'inline-start' and 'inline-end' with linear easing - assert_equals: The value should be inline-start at 0ms expected "inline-start" but got "none"

Categories

(Core :: DOM: Animation, defect, blocker)

52 Branch
defect
Not set
blocker

Tracking

()

RESOLVED FIXED
Tracking Status
firefox52 --- fixed
firefox53 --- wontfix
firefox54 --- wontfix

People

(Reporter: intermittent-bug-filer, Assigned: hiro)

References

Details

Attachments

(1 file)

Duplicate of this bug: 1333159
Component: web-platform-tests → DOM: Animation
Flags: needinfo?(hikezoe)
Product: Testing → Core
Version: Version 3 → 52 Branch
Severity: normal → blocker
'inline-start' and 'inline-end' are still behind the pref (bug 1253919), we should specify other values (e.g. left or right).
I will post a patch soon.
Flags: needinfo?(hikezoe)
See Also: → 1333295
We should also fix the values on trunk and aurora. I filed bug 1333295 for it.
Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
I accidentally pushed the patch for bug 1333295 to this bug.  Sorry for the spam.
Comment on attachment 8829711 [details]
Bug 1333154 - Use 'left' and 'right' for 'clear' property animation.

https://reviewboard.mozilla.org/r/106718/#review107730

Thanks Hiro!
Attachment #8829711 - Flags: review?(dakatsuka) → review+
https://hg.mozilla.org/releases/mozilla-beta/rev/7c6d7296c07d6df56a1f1a4a4861bb1e6f104c26

Thanks for the patch, Hiro!
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.