Select box selections are remembered but displayed incorrectly

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Leon Out, Assigned: Alexandru Savulov)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
At the sample URL, you can see that item 2 is selected when you first arrive at
the page. If you select a different item, then reload the page, the new item is
selected, but not highlighted. The original selected item, 2, is still
highlighted until it is moused-over. There are two possible solutions for this:
1. Remove the code that remembers the user's selections when the page is reloaded.
or
2. Make the "remembrance" code highlight the proper selection when the page is
reloaded.

The workaround for this bug is to reset the form when the page is loaded, using
document.formName.reset().

Comment 1

16 years ago
Could not reproduce in 2002032406 under linux.

Comment 2

16 years ago
cannot reproduce on build 2002-04-01-03-trunk windows 98... Leon ,What build are
you using?

Comment 3

16 years ago
Resolving due to lack of responce
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.