AccumulateEventRegions has scalability problems

RESOLVED DUPLICATE of bug 1363423

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1363423
2 years ago
a year ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

({perf})

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], URL)

(Reporter)

Description

2 years ago
https://people-mozilla.org/~jmuizelaar/webrender/synthetic/moving-balls.html spends most of it's time in AccumulateEventRegions.

There's a bunch of options for how we can do better.
(Reporter)

Comment 1

2 years ago
If we were to use TiledRegion we'd probably need a version that has different semantics. The current TiledRegion takes the bounds of the rects in a tile. We'd want something that uses the largest contained rectangle.
I feel like in the default webrender configuration we shouldn't really be doing anything in AccumulateEventRegions, because APZ is off and layout.event-regions.enabled is false by default. So we shouldn't be building event regions at all. Is that not the case?
Should this run any faster if the window size excludes most of the objects? (e.g. a 300x200 window) It performs just as poor for me, which is unintuitive.
(Reporter)

Comment 4

2 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> I feel like in the default webrender configuration we shouldn't really be
> doing anything in AccumulateEventRegions, because APZ is off and
> layout.event-regions.enabled is false by default. So we shouldn't be
> building event regions at all. Is that not the case?

This was profiled in a regular Nightly build without WebRender.
Ah, ok. I was thrown off by the URL.
Keywords: perf
Priority: -- → P3
Whiteboard: [gfx-noted]
Version: unspecified → 53 Branch

Updated

2 years ago
See Also: → bug 1363423
The patch in bug 1363423 reduces the paint time of this page from ~2500ms to ~300ms. Forward-duping.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1363423
You need to log in before you can comment on or make changes to this bug.