Videos fail to play at vivo.sx after Bug 1317947

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: miketaylr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webcompat], URL)

(Originally reported as https://webcompat.com/issues/4368)

The videos no longer load @ https://vivo.sx/f15f02653a. mozregression lead me here:

17:01.64 INFO: Last good revision: 3cbb93f5768e0e5ac470d3bb29cea58fe2f45df3
17:01.64 INFO: First bad revision: f296d03423848da45f1839b946b103047834b459
17:01.64 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3cbb93f5768e0e5ac470d3bb29cea58fe2f45df3&tochange=f296d03423848da45f1839b946b103047834b459

17:02.72 INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1317947

This also fails in Chrome Canary.



~*Note: this site is sketchy, probably illegal and the ads can be NSFW.*~
Franz, can you advise if this is something the site needs to fix? Thanks!
Flags: needinfo?(franziskuskiefer)
Whiteboard: [webcompat]
This doesn't seem related to NSS (or any browser). The TLS connection works fine. The resource is simply not accessible (by any browser I tested). (The one from comment 2.)
About https://vivo.sx/f15f02653a. I get the url from comment 2 served in FF (which obviously doesn't work) but https://delivery--rsc-3.vivo.sx/get/0059249650?e=1485275988&s=500&m=video/mp4&h=v5HQM1XJ7g-ac2AVijcrGA in Chromium (which works fine there as well as in FF).
Flags: needinfo?(franziskuskiefer)
Interesting, it works in FF release for me (and others on my team) and mozregression points to Bug 1317947, but not in 53+. Possibly some other change then.
Removing the blocker for bug 1317947 as it doesn't seem to be NSS related.
No longer blocks: 1317947
The linked videos work fine here.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.