Closed Bug 1333278 Opened 3 years ago Closed 3 years ago

Fx52 OSX Universal Cross-compile builds broken after the uplift to Beta

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox52 fixed, firefox53 unaffected, firefox54 unaffected)

RESOLVED FIXED
Tracking Status
firefox52 --- fixed
firefox53 --- unaffected
firefox54 --- unaffected

People

(Reporter: RyanVM, Assigned: ted)

References

Details

Attachments

(1 file)

After the fix for bug 1333230 landed, we still permafailures with these builds. Since they're not mission-critical at the moment, I'm going to be hiding them for now until they can be fixed up.

https://treeherder.mozilla.org/logviewer.html#?job_id=71327622&repo=mozilla-beta

INFO -  gmake[7]: Entering directory `/home/worker/workspace/build/src/obj-firefox/x86_64/browser/installer'
INFO -  OMNIJAR_NAME=omni.ja \
INFO -  	NO_PKG_FILES="core bsdecho js js-config jscpucfg nsinstall viewer TestGtkEmbed elf-dynstr-gc mangle* maptsv* mfc* msdump* msmap* nm2tsv* nsinstall* res/samples res/throbber shlibsign* certutil* pk12util* BadCertServer* OCSPStaplingServer* GenerateOCSPResponse* chrome/chrome.rdf chrome/app-chrome.manifest chrome/overlayinfo components/compreg.dat components/xpti.dat content_unit_tests necko_unit_tests *.dSYM " \
[task 2017-01-24T00:08:23.791827Z] 00:08:23     INFO -  	/home/worker/workspace/build/src/obj-firefox/x86_64/_virtualenv/bin/python /home/worker/workspace/build/src/toolkit/mozapps/installer/packager.py -DMOZ_APP_NAME=firefox -DPREF_DIR=defaults/preferences -DJAREXT= -DMOZ_CHILD_PROCESS_NAME=plugin-container -DMOZ_SHARED_MOZGLUE=1 -DNECKO_WIFI -DDLL_PREFIX=lib -DDLL_SUFFIX=.dylib -DBIN_SUFFIX= -DDIR_MACOS=Contents/MacOS/ -DDIR_RESOURCES=Contents/Resources/ -DMOZ_FOLD_LIBS=1 -DAPPNAME=Firefox.app -DBINPATH=/Firefox.app/Contents/MacOS -DRESPATH=Firefox.app/Contents/Resources -DLPROJ_ROOT=en -DMOZ_ICU_VERSION=58 -DMOZ_ICU_DATA_ARCHIVE -DMOZ_ICU_DBG_SUFFIX= -DICU_DATA_FILE=icudt58l.dat -DCLANG_CXX -DACCESSIBILITY=1 -DBUILD_CTYPES=1 -DCROSS_COMPILE=1 -DD_INO=d_ino -DEARLY_BETA_OR_EARLIER=1 -DENABLE_INTL_API=1 -DENABLE_MARIONETTE=1 -DENABLE_SYSTEM_EXTENSION_DIRS=1 -DENABLE_TESTS=1 -DEXPOSE_INTL_API=1 -DFIREFOX_VERSION=52.0 -DFORCE_PR_LOG=1 -DGTEST_HAS_RTTI=0 -DHAVE_64BIT_BUILD=1 -DHAVE_ALLOCA_H=1 -DHAVE_ARC4RANDOM=1 -DHAVE_ARC4RANDOM_BUF=1 -DHAVE_CPUID_H=1 -DHAVE_DIRENT_H=1 -DHAVE_DLADDR=1 -DHAVE_GETOPT_H=1 -DHAVE_GMTIME_R=1 -DHAVE_I18N_LC_MESSAGES=1 -DHAVE_INTTYPES_H=1 -DHAVE_LANGINFO_CODESET=1 -DHAVE_LCHOWN=1 -DHAVE_LOCALECONV=1 -DHAVE_LOCALTIME_R=1 -DHAVE_LSTAT64=1 -DHAVE_MEMMEM=1 -DHAVE_NETINET_IN_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_POSIX_MEMALIGN=1 -DHAVE_PTHREAD_H=1 -DHAVE_SA_LEN=1 -DHAVE_SCONN_LEN=1 -DHAVE_SETPRIORITY=1 -DHAVE_SIN6_LEN=1 -DHAVE_SIN_LEN=1 -DHAVE_STAT64=1 -DHAVE_STDINT_H=1 -DHAVE_STRERROR=1 -DHAVE_STRNDUP=1 -DHAVE_SYSCALL=1 -DHAVE_SYS_QUEUE_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_THREAD_TLS_KEYWORD=1 -DHAVE_UNISTD_H=1 -DHAVE_VALLOC=1 -DHAVE_VA_COPY=1 -DHAVE_VA_LIST_AS_ARRAY=1 -DHAVE_VISIBILITY_ATTRIBUTE=1 -DHAVE_VISIBILITY_HIDDEN_ATTRIBUTE=1 -DHAVE__UNWIND_BACKTRACE=1 -DHAVE___CXA_DEMANGLE=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DMALLOC_H='<malloc/malloc.h>' -DMALLOC_USABLE_SIZE_CONST_PTR=const -DMOZILLA_OFFICIAL=1 -DMOZILLA_UAVERSION='"52.0"' -DMOZILLA_VERSION='"52.0"' -DMOZILLA_VERSION_U=52.0 -DMOZ_ADDON_SIGNING=1 -DMOZ_APPLEMEDIA=1 -DMOZ_APP_UA_NAME='""' -DMOZ_APP_UA_VERSION='"52.0"' -DMOZ_B2G_OS_NAME='""' -DMOZ_B2G_VERSION='"1.0.0"' -DMOZ_BUILD_APP=browser -DMOZ_CLANG_PLUGIN=1 -DMOZ_CONTENT_SANDBOX=1 -DMOZ_CRASHREPORTER=1 -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DMOZ_DATA_REPORTING=1 -DMOZ_DISTRIBUTION_ID='"org.mozilla"' -DMOZ_DLL_SUFFIX='".dylib"' -DMOZ_ENABLE_PROFILER_SPS=1 -DMOZ_ENABLE_SIGNMAR=1 -DMOZ_ENABLE_SKIA=1 -DMOZ_FEEDS=1 -DMOZ_FFMPEG=1 -DMOZ_FFVPX=1 -DMOZ_FMP4=1 -DMOZ_GAMEPAD=1 -DMOZ_GMP_SANDBOX=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DMOZ_JSDOWNLOADS=1 -DMOZ_LIBAV_FFT=1 -DMOZ_LOGGING=1 -DMOZ_MACBUNDLE_ID=org.mozilla.firefox -DMOZ_MEMORY=1 -DMOZ_MEMORY_DARWIN=1 -DMOZ_OFFICIAL_BRANDING=1 -DMOZ_PEERCONNECTION=1 -DMOZ_PERMISSIONS=1 -DMOZ_PHOENIX=1 -DMOZ_PLACES=1 -DMOZ_RAW=1 -DMOZ_REQUIRE_SIGNING=1 -DMOZ_RUST_MP4PARSE=1 -DMOZ_RUST_URLPARSE=1 -DMOZ_SAMPLE_TYPE_FLOAT32=1 -DMOZ_SANDBOX=1 -DMOZ_SCTP=1 -DMOZ_SECUREELEMENT=1 -DMOZ_SERVICES_HEALTHREPORT=1 -DMOZ_SRTP=1 -DMOZ_STACKWALKING=1 -DMOZ_STATIC_JS=1 -DMOZ_TELEMETRY_REPORTING=1 -DMOZ_TREE_CAIRO=1 -DMOZ_TREE_PIXMAN=1 -DMOZ_UPDATER=1 -DMOZ_UPDATE_CHANNEL=beta -DMOZ_USER_DIR='"Mozilla"' -DMOZ_VERIFY_MAR_SIGNATURE=1 -DMOZ_VORBIS=1 -DMOZ_VPX_ERROR_CONCEALMENT=1 -DMOZ_VPX_NO_MEM_REPORTING=1 -DMOZ_WEBGL_CONFORMANT=1 -DMOZ_WEBM_ENCODER=1 -DMOZ_WEBRTC=1 -DMOZ_WEBRTC_ASSERT_ALWAYS=1 -DMOZ_WEBRTC_SIGNALING=1 -DMOZ_WEBSPEECH=1 -DMOZ_WEBSPEECH_TEST_BACKEND=1 -DMOZ_WIDGET_COCOA=1 -DMOZ_XUL=1 -DNO_NSPR_10_SUPPORT=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DRELEASE_OR_BETA=1 -DSPIDERMONKEY_PROMISE=1 -DSTATIC_JS_API=1 -DSTDC_HEADERS=1 -DTARGET_XPCOM_ABI='"x86_64-gcc3"' -DUSE_SKIA=1 -DUSE_SKIA_GPU=1 -DU_STATIC_IMPLEMENTATION=1 -DU_USING_ICU_NAMESPACE=0 -DVA_COPY=va_copy -DVPX_X86_ASM=1 -DXP_DARWIN=1 -DXP_MACOSX=1 -DXP_UNIX=1 -DAB_CD=en-US \
INFO -  		--format omni \
INFO -  		--removals /home/worker/workspace/build/src/browser/installer/removed-files.in \
INFO -  		 \
INFO -  		 \
INFO -  		 \
INFO -  		 \
INFO -  		--optimizejars \
INFO -  		 \
INFO -  		--unify /home/worker/workspace/build/src/obj-firefox/x86_64/../i386/dist \
INFO -  		/home/worker/workspace/build/src/browser/installer/package-manifest.in ../../dist ../../dist/universal/firefox \
INFO -  ../../config/nsinstall -D ../../dist/
INFO -  /home/worker/workspace/build/src/obj-firefox/x86_64/_virtualenv/bin/python /home/worker/workspace/build/src/toolkit/mozapps/installer/informulate.py \
INFO -  		../../dist//target.json \
INFO -  		BUILDID=20170123233059 \
INFO -  		MOZ_SOURCE_REPO=MOZ_SOURCE_REPO=https://hg.mozilla.org/releases/mozilla-beta \
INFO -  		MOZ_SOURCE_STAMP=26543b415dc40719c869fc63e24af711f47622cf \
INFO -  		MOZ_PKG_PLATFORM=mac
INFO -  cp ../../mozinfo.json ../../dist//target.mozinfo.json
INFO -  echo "buildID=20170123233059" > ../../dist//target_info.txt
INFO -  strip:/tmp/tmp2SUpRd: File format not recognized
INFO -  Traceback (most recent call last):
INFO -    File "/home/worker/workspace/build/src/toolkit/mozapps/installer/packager.py", line 415, in <module>
INFO -      main()
INFO -    File "/home/worker/workspace/build/src/toolkit/mozapps/installer/packager.py", line 411, in main
INFO -      copier.copy(args.destination)
INFO -    File "/home/worker/workspace/build/src/python/mozbuild/mozpack/copier.py", line 399, in copy
INFO -      copy_results.append((destfile, f.copy(destfile, skip_if_older)))
INFO -    File "/home/worker/workspace/build/src/python/mozbuild/mozpack/unify.py", line 88, in copy
INFO -      os.unlink(f)
INFO -  OSError: [Errno 2] No such file or directory: '/tmp/tmp2SUpRd'
INFO -  gmake[7]: *** [stage-package] Error 1
Blocks: 1333279
The culprit is here:
https://dxr.mozilla.org/mozilla-central/rev/5a4412474c63e1d9e66036d603ac42e9cb2b9150/build/macosx/universal/mozconfig.common#44

That needs to be "${TOOLCHAIN_PREFIX}strip" like the others. This doesn't break elsewhere because we don't strip binaries on Nightly and Aurora because we have --enable-profiling on.
Assignee: nobody → ted
I didn't test this patch, but it shouldn't actually do anything on central anyway because we disabled universal builds there.
Comment on attachment 8829965 [details]
bug 1333278 - set right path to STRIP for cross-compiled OS X universal builds.

https://reviewboard.mozilla.org/r/106926/#review107978
Attachment #8829965 - Flags: review?(mshal) → review+
We have confirmed green tc(Bu) builds on Beta \m/
https://hg.mozilla.org/releases/mozilla-beta/rev/0916e803079e
Unfortunately, the non-universal builds are still broken in a different way. I'll file a new bug to track that, however.
https://treeherder.mozilla.org/logviewer.html#?job_id=71671913&repo=mozilla-beta
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.