Closed Bug 1333309 Opened 4 years ago Closed 3 years ago

Calling PlacesUtils.bookmarks.eraseEverything() causes JS warnings

Categories

(Toolkit :: Places, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1366829

People

(Reporter: markh, Unassigned)

Details

Noticed via our test suit - it calls eraseEverying with no params, causing:

> JavaScript strict warning: resource://gre/modules/Bookmarks.jsm, line 1599: ReferenceError: reference to undefined property "source"

The issue appears to be that a few places dereference options.source, but no "options" param was specified.
Summary: Calling PlacesUtils.bokmarks.eraseEverything() causes JS warnings → Calling PlacesUtils.bookmarks.eraseEverything() causes JS warnings
Priority: -- → P3
I fixed this in bug 1366829.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1366829
You need to log in before you can comment on or make changes to this bug.