Closed Bug 133352 Opened 19 years ago Closed 19 years ago

table css height: 100% rendered wrong (not stretch) (body not defaulted to 100% heigh)

Categories

(Core :: Layout: Tables, defect, P3)

x86
Windows XP
defect

Tracking

()

RESOLVED DUPLICATE of bug 119409

People

(Reporter: andris, Assigned: karnaze)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)
BuildID:    2002031104

The gray column on the page http://andri.estpak.ee/strange.html should stretch 
all the way down to the end of the page. IE 6.0, Konqueror show it like it 
should be.

Either this or all other browsers do it wrong ;-)

Reproducible: Always
Steps to Reproduce:
Go to http://andri.estpak.ee/strange.html
Over to HTMLTables.
Assignee: jst → karnaze
Component: DOM Style → HTMLTables
QA Contact: ian → amar
To correct this set your <body> to 100% height, position: absolute; may also be
required.
confirming with 2002052806 on win2k

using table height="100%" instead via a style tag works.

this is a valid bug in my point of view
Same happens here, though height is 90%: 
http://www.alias.fi/extra

Login texts should be somewhat centered.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
original testcase dosn't work. Suspecting a dupe of bug 88035.
doubt it, bug 88035 is realted to div or center.
mozilla seems to completly ignore the css height in this case, no div or center
in the testcase
Summary: table with a Height: 100%; rendered wrong → table css height: 100% rendered wrong (not stretch) (body not defaulted to 100% heigh)

*** This bug has been marked as a duplicate of 119409 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.