Ghost windows with 17 add-ons

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: glasserc, Unassigned)

Tracking

(Blocks: 1 bug)

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8830031 [details]
memory-report.json.gz

I saw Jörg Sommer's thread on firefox-dev recently and tried to repeat the steps, but got different results:

4,455.19 MB (100.0%) -- explicit
├──2,228.20 MB (50.01%) -- window-objects
│  ├──1,334.92 MB (29.96%) -- top(none)
│  │  ├──1,001.41 MB (22.48%) -- detached
│  │  │  ├────642.35 MB (14.42%) ++ (150 tiny)
│  │  │  ├────101.50 MB (02.28%) ++ window(about:memory)
│  │  │  ├─────76.28 MB (01.71%) -- window(https://www.google.com/maps/...)
│  │  │  │     ├──69.88 MB (01.57%) -- js-compartment(https://www.google.com/maps)
│  │  │  │     │  ├──68.46 MB (01.54%) ++ classes
│  │  │  │     │  └───1.43 MB (00.03%) ++ (4 tiny)
│  │  │  │     └───6.40 MB (00.14%) ++ (3 tiny)
│  │  │  ├─────73.17 MB (01.64%) -- window(https://www.google.com/maps/...)
│  │  │  │     ├──68.22 MB (01.53%) -- js-compartment(https://www.google.com/maps)
│  │  │  │     │  ├──67.16 MB (01.51%) ++ classes
│  │  │  │     │  └───1.06 MB (00.02%) ++ (4 tiny)
│  │  │  │     └───4.95 MB (00.11%) ++ (3 tiny)
│  │  │  ├─────55.87 MB (01.25%) -- window(https://www.google.com/maps/...)
│  │  │  │     ├──51.68 MB (01.16%) -- js-compartment(https://www.google.com/maps)
│  │  │  │     │  ├──50.67 MB (01.14%) ++ classes
│  │  │  │     │  └───1.01 MB (00.02%) ++ (4 tiny)
│  │  │  │     └───4.19 MB (00.09%) ++ (3 tiny)
│  │  │  └─────52.25 MB (01.17%) ++ window(chrome://browser/content/browser.xul)

It seems strange to me that there are three windows open to Google Maps, when I don't have any tabs open to it at the moment. I'm guessing these are being kept around due to an add-on or something? I currently have installed:

Amazon Smile Redirect	0.1.1.1-signed.1-signed	true	jid1-VgrLFatWWJY3DA@jetpack
BugzillaJS	3.5.0	true	jid0-NgMDcEu2B88AbzZ6ulHodW9sJzA@jetpack
FoxClocks	4.2.3	true	{d37dc5d0-431d-44e5-8c91-49419370caa1}
Min Vid	0.3.3	true	@min-vid
moz://a protocol handler	0.1.0	true	moz-handler@mozilla.org
Multi-process staged rollout	1.5	true	e10srollout@mozilla.org
No More 404s	1.7.0	true	wayback_machine@mozilla.org
Page Shot	4.3.201701052116	true	jid1-NeEaf3sAHdKHPA@jetpack
Pocket	1.0.5	true	firefox@getpocket.com
Tab Center	1.29.0	true	tabcentertest1@mozilla.com
Test Pilot	0.9.3-dev-e085559	true	@testpilot-addon
Tracking Protection Experiment	1.1	true	blok@mozilla.org
Twitter Link Expander	1.0.0	true	jid1-DwRap1pOaj8qgQ@jetpack
Web Compat	1.0	true	webcompat@mozilla.org
You're Not So Special	1.1	true	you-re-not-so-special@betacantrips.com
About Sync extension for Firefox	0.0.6	false	aboutsync@mhammond.github.com
Activity Stream	1.2.0	false	@activity-streams

(I just disabled About Sync and Activity Stream since I don't use them, but they could still be related.) Does anything seem suspicious here?
Ethan, it looks like you have a leaky add-on (and a ton of ghost windows). Can you try reproducing in safe mode? If you don't see the leaks then you can try re-enabling add-ons selectively.
Flags: needinfo?(eglassercamp)
Summary: Please help me track down a memory leak → Ghost windows with 17 add-ons
Blocks: 1181677
(Reporter)

Comment 2

a year ago
Never mind, in the intervening month I have switched to using Nightly on this computer and I no longer have Firefox open long enough to encounter this kind of issue. Thanks for the help.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(eglassercamp)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.