Closed Bug 1333574 Opened 5 years ago Closed 4 years ago

mousemove event while in Pointerlock mode

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

51 Branch
All
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox51 --- affected
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected

People

(Reporter: renambot, Unassigned)

Details

(Whiteboard: [specification][type:bug])

What did you do?
================
1. https://threejs.org/examples/#misc_controls_pointerlock
2. http://www.smartjava.org/examples/pointerlock/
3. Try these examples: while in pointerLock the mouse move event are bogus

What happened?
==============
Not getting correct data in mousemove event while in pointerLock

What should have happened?
==========================
it should be better

Is there anything else we should know?
======================================
Forgot to mention: it used to work before 51, and seems to work in 52, 53, 54.
Component: API → Untriaged
Product: Mozilla Developer Network → Firefox
Can you explain more in detail what the the problem is with your mousemove events?
Flags: needinfo?(renambot)
(In reply to Justin [:JW_SoftvisionQA] from comment #2)
> Can you explain more in detail what the the problem is with your mousemove
> events?

Click: http://www.smartjava.org/examples/pointerlock/
it should produce the same behavior in both windows.
But now, in v51, the pointer gets stuck around position 0,0 during Pointerlock, mode used in games. That's annoying because people were getting excited about WebGL2.
See also: https://blog.playcanvas.com/mozilla-launches-webgl-2-with-playcanvas/
Bug triage day (2017-01-30) I'm using Nightly 54 It works perfectly with my browser. After click that picture my mouse pointer disappear and 360degree image works . After clicking escape button my mouse pointer appears..
Interesting. I still can not reproduce this issue. it works perfectly on my browser also.
Im using firefox developer edition and windows10 os it works for me..
[bugday-20170130]
OS:Windows 8.1, Browser: Firefox Nightly 54.0a1. I tried to reproduce your bug but i cant reproduce it, it works correctly for me.
It seems fine on Linux and Windows, but broken on Mac.
it used to work before 51, and seems to work in 52, 53, 54.
I was only testing on windows previously but after comment 8 I tested on Mac and was able to reproduce. I am thinking this will be a graphics issue.
Component: Untriaged → Graphics
Flags: needinfo?(renambot)
OS: Other → Mac OS X
Product: Firefox → Core
Version: unspecified → 51 Branch
Component: Graphics → Event Handling
[bugday-20170130]
OS: Windows 8.1, Browser: Firefox Nightly 54.0a1.
it works correctly for me.
OS: Fedora 25, 
Browser : Firefox Nightly 54.0a1. 

Unable to reproduce the bug.
Going to close this as WORKSFORME, since all the latest versions don't have this issue, and this is not serious enough to have a dot line branch for 51.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Fixed on Mac now running v52.0
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.