1,409,600 instances of "NS_FAILED GetHistogramByEnumId for CHILD" emitted from toolkit/components/telemetry/TelemetryHistogram.cpp during debug testing

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: erahm, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

> 1409644 WARNING: NS_FAILED GetHistogramByEnumId for CHILD: file toolkit/components/telemetry/TelemetryHistogram.cpp, line 1404

This warning [1] shows up in the following test suites:

> 198157 - test-linux64/debug-mochitest-media-e10s mda
>  93505 - test-linux64/debug-mochitest-e10s-9 9
>  86077 - test-linux64/debug-mochitest-e10s-6 6
>  48546 - test-linux64/debug-mochitest-e10s-8 8
>  44626 - test-linux64/debug-web-platform-tests-e10s-8 8
>  44011 - test-linux64/debug-mochitest-e10s-3 3
>  43363 - test-linux64/debug-mochitest-e10s-2 2
>  42709 - test-linux64/debug-web-platform-tests-e10s-12 12
>  35935 - test-linux64/debug-web-platform-tests-e10s-11 11
>  35704 - test-linux64/debug-web-platform-tests-e10s-6 6
>  34188 - test-linux64/debug-mochitest-devtools-chrome-e10s-5 dt5
>  32796 - test-linux64/debug-mochitest-devtools-chrome-e10s-4 dt4
>  31898 - test-linux64/debug-mochitest-e10s-5 5
>  29741 - test-linux64/debug-mochitest-browser-chrome-e10s-11 bc11
>  27018 - test-linux64/debug-web-platform-tests-e10s-10 10
>  26195 - test-linux64/debug-web-platform-tests-e10s-5 5
>  25519 - test-linux64/debug-web-platform-tests-e10s-3 3
>  23284 - test-linux64/debug-mochitest-e10s-10 10
>  22287 - test-linux64/debug-mochitest-browser-chrome-e10s-10 bc10
>  22284 - test-linux64/debug-mochitest-e10s-7 7
>  21558 - test-linux64/debug-mochitest-browser-chrome-e10s-12 bc12
>  21547 - test-linux64/debug-mochitest-browser-chrome-e10s-3 bc3
>  21127 - test-linux64/debug-web-platform-tests-e10s-1 1
>  21029 - test-linux64/debug-web-platform-tests-e10s-7 7
>  19920 - test-linux64/debug-mochitest-browser-chrome-e10s-6 bc6
>  19553 - test-linux64/debug-web-platform-tests-e10s-2 2
>  19262 - test-linux64/debug-mochitest-devtools-chrome-e10s-10 dt10
>  18775 - test-linux64/debug-mochitest-clipboard-e10s cl
>  18677 - test-linux64/debug-web-platform-tests-reftests-e10s Wr
>  18598 - test-linux64/debug-mochitest-devtools-chrome-e10s-9 dt9
>  17869 - test-linux64/debug-mochitest-webgl-e10s-3 gl3
>  17117 - test-linux64/debug-mochitest-webgl-e10s-1 gl1
>  15850 - test-linux64/debug-mochitest-browser-chrome-e10s-7 bc7
>  15711 - test-linux64/debug-mochitest-webgl-e10s-2 gl2
>  14852 - test-linux64/debug-mochitest-devtools-chrome-e10s-6 dt6
>  14828 - test-linux64/debug-mochitest-devtools-chrome-e10s-3 dt3
>  14384 - test-linux64/debug-mochitest-browser-chrome-e10s-8 bc8
>  14374 - test-linux64/debug-mochitest-browser-chrome-e10s-1 bc1
>  14333 - test-linux64/debug-mochitest-browser-chrome-e10s-4 bc4
>  14251 - test-linux64/debug-web-platform-tests-e10s-4 4
>  13409 - test-linux64/debug-mochitest-browser-chrome-e10s-5 bc5
>  13132 - test-linux64/debug-mochitest-e10s-1 1
>  12807 - test-linux64/debug-mochitest-devtools-chrome-e10s-7 dt7
>  11895 - test-linux64/debug-mochitest-devtools-chrome-e10s-1 dt1
>   9940 - test-linux64/debug-mochitest-browser-chrome-e10s-2 bc2
>   9930 - test-linux64/debug-mochitest-devtools-chrome-e10s-8 dt8
>   9838 - test-linux64/debug-mochitest-devtools-chrome-e10s-2 dt2
>   9573 - test-linux64/debug-mochitest-e10s-4 4
>   7859 - test-linux64/debug-mochitest-browser-chrome-e10s-9 bc9
>   2795 - test-linux64/debug-firefox-ui-functional-remote-e10s en-US
>   1710 - test-linux64/debug-mochitest-2 2
>   1101 - test-linux64/debug-mochitest-gpu-e10s gpu
>    970 - test-linux64/debug-firefox-ui-functional-local-e10s en-US
>    773 - test-linux64/debug-mochitest-chrome-1 c1
>    581 - test-linux64/debug-mochitest-4 4
>    542 - test-linux64/debug-mochitest-clipboard cl
>    525 - test-linux64/debug-mochitest-chrome-3 c3
>    385 - test-linux64/debug-mochitest-browser-chrome-7 bc7
>     79 - test-linux64/debug-mochitest-3 3
>     79 - test-linux64/debug-mochitest-chrome-2 c2
>     74 - test-linux64/debug-mochitest-browser-chrome-1 bc1
>     72 - test-linux64/debug-mochitest-10 10
>     50 - test-linux64/debug-mochitest-a11y a11y
>     42 - test-linux64/debug-mochitest-8 8
>     25 - test-linux64/debug-mochitest-1 1

It shows up in 10225 tests. A few of the most prevalent:

>  18198 - [e10s] layout/style/test/test_value_computation.html
>  17114 - [e10s] Shutdown
>  14675 - [e10s] layout/style/test/test_property_syntax_errors.html
>  11959 - [e10s] dom/media/tests/mochitest/test_peerConnection_verifyAudioAfterRenegotiation.html
>   9639 - [e10s] layout/style/test/test_garbage_at_end_of_declarations.html
>   8609 - [e10s] /quirks-mode/hashless-hex-color.html
>   8349 - [e10s] /media-source/mediasource-appendbuffer-quota-exceeded.html
>   8285 - [e10s] layout/base/tests/test_reftests_with_caret.html
>   6299 - [e10s] parser/htmlparser/tests/mochitest/test_html5_tree_construction.html
>   5835 - [e10s] parser/htmlparser/tests/mochitest/test_html5_tree_construction_part2.html

[1] https://hg.mozilla.org/integration/mozilla-inbound/annotate/b2239bbe0c45/toolkit/components/telemetry/TelemetryHistogram.cpp#l1404
This gets the reward for most egregious warning regression I've seen. It's causing intermittent failures due to test logs growing beyond their size limit. It seems to be cross platform.
Summary: 1,409,600 instances of "NS_FAILED GetHistogramByEnumId for CHILD" emitted from toolkit/components/telemetry/TelemetryHistogram.cpp during linux64 debug testing → 1,409,600 instances of "NS_FAILED GetHistogramByEnumId for CHILD" emitted from toolkit/components/telemetry/TelemetryHistogram.cpp during debug testing
Chris it looks like you added this warning bug 1218576, can you help triage this? It seems like the actual regression is within the last week.
Flags: needinfo?(chutten)
I just backed out bug 1331804 and bug 1332100 for breaking tests due to log bloat. I assume that's what this is.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Eric, does this still happen with those two bugs backed out? (not the failures, but the egregious logspam?) It's not supposed to happen at all unless Telemetry's specifically being asked to find histograms that don't exist.
Flags: needinfo?(chutten) → needinfo?(erahm)
(In reply to Chris H-C :chutten from comment #4)
> Eric, does this still happen with those two bugs backed out? (not the
> failures, but the egregious logspam?) It's not supposed to happen at all
> unless Telemetry's specifically being asked to find histograms that don't
> exist.

Yes the latest m-c is fixed.
Flags: needinfo?(erahm)
You need to log in before you can comment on or make changes to this bug.