Firefox 51.0.1 build1 partial generation fails due to clamav errors

RESOLVED WONTFIX

Status

Release Engineering
Release Requests
P1
normal
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: rail, Assigned: rail)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

MozReview Requests

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Assignee)

Description

a year ago
See https://tools.taskcluster.net/task-inspector/#5vza17xTR52X2RwfAUW9PQ/

I ran the task locally and found that clamav complains about libGLESv2.dll https://archive.mozilla.org/pub/firefox/releases/50.0.2/update/win64/en-US/firefox-50.0.2.complete.mar


libGLESv2.dll: Win.Trojan.Agent-1888872 FOUND

----------- SCAN SUMMARY -----------
Known viruses: 5655235
Engine version: 0.98.7
Scanned directories: 0
Scanned files: 1
Infected files: 1
Data scanned: 1.81 MB
Data read: 1.74 MB (ratio 1.04:1)
Time: 8.952 sec (0 m 8 s)

I scanned the file using https://www.virustotal.com/en/file/52408dd1941f9015750bc763c6511fd048a4dbc29d0a4342071c87658e93f813/analysis/ and it looks like this is a false positive.

As a possible workaround we can disable AV scan in funsize and go with build2.
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Assignee: nobody → rail

Comment 2

a year ago
mozreview-review
Comment on attachment 8830140 [details]
Bug 1333663 - Temporarily disable AV in funsize due to false positive in ClamAV. , a=release

https://reviewboard.mozilla.org/r/107040/#review108128

Let's make sure to back this out when we resolve the false positive :)
Attachment #8830140 - Flags: review?(aki) → review+
(Assignee)

Comment 4

a year ago
We'll need to manually AV-scan the old-school way these files and revert the patch at some point.
(Assignee)

Comment 5

a year ago
I scanned the files manually using https://gist.github.com/rail/ac60089ac773b3a0a94453ac51587015. All fine!
(Assignee)

Comment 6

a year ago
Just checked the status of the ClamAV DB and it still detects something in 50.0.2 :/
(Assignee)

Updated

a year ago
Priority: -- → P1
(Assignee)

Comment 7

a year ago
This worked fine in 52.0
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.